Problem Description

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

Input

Each test case contains only a number n ( 0< n < = 10^5) in a line.

Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

Sample Input

1

5

Sample Output

1

0

Hinthint

Consider the second test case:

The initial condition : 0 0 0 0 0 …

After the first operation : 1 1 1 1 1 …

After the second operation : 1 0 1 0 1 …

After the third operation : 1 0 0 0 1 …

After the fourth operation : 1 0 0 1 1 …

After the fifth operation : 1 0 0 1 0 …

The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

思路:

说下题目大意吧,

先把这些灯标上号,1 2 3 4 5 6 7 8 ……无穷

首先全是关的,也就是全是0

第一次操作 ,标号是1的倍数,全都变成相反的状态,也就是全变成1.。

第二次操作 ,标号是2的倍数,全都变成相反的状态,你可以看下,2 4 6……变成了0.。。

第三次操作 ,标号是3的倍数,全都变成相反的状态,你可以看下,3 6 9……

他问你 N 号台灯最后 变成了 什么状态,

例如 1号灯,最后变成了1,不管多少次操作都是1.。

例如 5号灯 最后变成了0,不管多少次操作都是0.。

当操作次数大于N的时候 N的状态就不会改变了,因为N不会是M(M>N)的倍数。。

本题思路很简单就是求n有几个约数(包括1和自身)如果有奇数个约数,变奇数次,结果也就是1;否则为0

import java.util.Scanner;

public class Main {
// static boolean[] islight = new boolean[100002]; public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
int n = sc.nextInt(); // for(int i=1;i<=n;i++){
// islight[i] = false;
// }
//
// for (int i = 1; i <= n; i++) {
// for (int j = 1; j <= n; j++) {
// if(j%i==0){
// islight[j] = !islight[j];
// }
// }
// }
//
// if(islight[n]){
// System.out.println("1");
// }else{
// System.out.println("0");
// }
// 超时 int k =0;
for(int i=1;i<=n;i++){
if(n%i==0){
k++;
}
} if(k%2==0){
System.out.println("0");
}else{
System.out.println("1");
} } }
}

最新文章

  1. Mono的简单例子
  2. 我为什么很烦在DB服务器上安装杀毒软件
  3. ios设备mdm的实现过程
  4. 欧几里德与扩展欧几里德算法 Extended Euclidean algorithm
  5. [原创]CI持续集成系统环境---部署Jenkins完整记录
  6. 设置mysql服务器远程连接
  7. LINQ2EF-LINQ2SQL-LINQ笔记
  8. jsp页面可以巧用模态框
  9. 利用ant的javac任务来编译程序使用ant的java任务来运行程序
  10. js 正则之检测素数
  11. Openjudge-计算概论(A)-整数奇偶排序
  12. mac mysql下载
  13. 使用邮件监控Mxnet训练
  14. Python三元运算
  15. Mac下安装mongdb
  16. mysql 安装问题三:FATAL ERROR: please install the following Perl modules before executing ./scripts/mysql_install_db: Data::Dumper
  17. ArcEngine临时数据存储 创建内存工作空间
  18. MySql开启远程用户登录GRANTALLPRIVILEGESON*.*TO&#39;root&#39;@&#39;%&#39;I MySql开启远程用户登录GRANTALLPRIVILEGESON*.*TO&#39;root&#39;@&#39;%&#39;I
  19. DFS遍历中forward、backward以及cross边的界定
  20. Yarn中ResourceManager的RPC协议

热门文章

  1. uploadify插件实现多个图片上传并预览
  2. 快速打出System.out.println(&quot;&quot;);
  3. 服务器证书安装配置指南(IIS7.5) 分类: ASP.NET 2014-11-05 12:39 105人阅读 评论(0) 收藏
  4. c++ string用法
  5. sql查询一个班级中总共有多少人以及男女分别多少人
  6. iOS适配:Masonry介绍与使用实践:快速上手Autolayout
  7. POJ1258-Agri-Net-ACM
  8. YII 集成jquery
  9. python学习第五天 List和tuple类型介绍及其List切片
  10. SharePoint 设置Lookup 字段的值