Stars

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 37323 Accepted: 16278

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999

线段树和树状数组皆可AC

树状数组(和金巨学的)

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <string>
#include <queue>
#include <vector>
#include <algorithm>
#define LL long long
using namespace std; const int INF = 0x3f3f3f3f; const int MAX = 32010; int c[MAX]; int level[MAX/2]; int lowbit(int x)
{
return x&(-x);
} int sum(int x)
{
int sum=0;
while(x>0)
{
sum+=c[x];
x-=lowbit(x);
}
return sum;
} void add(int x)
{
while(x<MAX)
{
c[x]++;
x+=lowbit(x);
}
} int main()
{
int n;
int x,y;
memset(level,0,sizeof(level));
memset(c,0,sizeof(c));
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d %d",&x,&y);
++x;
level[sum(x)]++;
add(x);
}
for(int i=0;i<n;i++)
{
printf("%d\n",level[i]);
}
return 0;
}

线段树

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <string>
#include <queue>
#include <vector>
#include <algorithm>
#define LL long long
using namespace std; const int INF = 0x3f3f3f3f; const LL MAX = 32000; int a[MAX*4];
int level[MAX]; int Query(int L,int R,int l,int r,int site)
{
if(L==l&&R==r)
{
return a[site];
}
int mid=(L+R)>>1;
if(r<=mid)
{
return Query(L,mid,l,r,site<<1);
}
else if(l>mid)
{
return Query(mid+1,R,l,r,site<<1|1);
}
else
{
return Query(L,mid,l,mid,site<<1)+Query(mid+1,R,mid+1,r,site<<1|1);
}
}
void update(int L,int R,int s,int site)
{
a[site]++;
if(L==R)
{
return ;
}
int mid=(L+R)>>1;
if(s<=mid)
{
update(L,mid,s,site<<1);
}
else
{
update(mid+1,R,s,site<<1|1);
}
}
int main()
{
int n;
int x,y;
memset(level,0,sizeof(level));
memset(a,0,sizeof(a));
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d %d",&x,&y);
level[Query(0,MAX,0,x,1)]++;
update(0,MAX,x,1);
}
for(int i=0;i<n;i++)
{
printf("%d\n",level[i]);
}
return 0;
}

最新文章

  1. 《ASP.NET MVC4 WEB编程》学习笔记------Web API 续
  2. FLASH CC 2015 CANVAS (四)制作响应式设计(自适应)的项目
  3. Java学习笔记(1)
  4. (转)SQL流程控制语句学习(一):变量及控制语句种类
  5. ToString()和Convert.ToString()的区别
  6. SQL Server identity种子
  7. RII K25A 语音空中飞鼠 红外学习步骤
  8. c++异常处理第四篇---不使用try catch语句,使用Loki::ScopeGuard
  9. C++ CRTP singleton
  10. bootsect及setup
  11. 网络学习day01_计算机网络与分层思想
  12. PHP入门——基本巩固
  13. docker--centos镜像安装tomcat jdk1.8 mysql部署java web项目
  14. amd,cmd规范
  15. git忽略规则.gitignore未生效解决办法
  16. Django rest framework集成微博第三方登录
  17. 【BZOJ2000】[HNOI2000]取石头游戏(贪心,博弈论)
  18. D3开发中的资料整理
  19. Java中测试StringBuilder、StringBuffer、String在字符串拼接上的性能
  20. .Net Core Web应用发布至IIS后报“An error occurred while starting the application”错误

热门文章

  1. Java基础之在窗口中绘图——使用模型/视图体系结构在视图中绘图(Sketcher 1 drawing a 3D rectangle)
  2. Java基础之读文件——使用通道读二进制数据(ReadPrimes)
  3. Postfix Completion 的使用
  4. 关闭VS实时调试器
  5. YbRapidSolution.MVC项目首页缓存没有起作用
  6. java post请求
  7. AR 应收 表
  8. jquery 下拉菜单
  9. 创建数据库和表的SQL语句【转】
  10. Android开机自启动程序