转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://poj.org/problem?

id=2488

----------------------------------------------------------------------------------------------------------------------------------------------------------
欢迎光临天资小屋http://user.qzone.qq.com/593830943/main

----------------------------------------------------------------------------------------------------------------------------------------------------------

Description

Background 

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans? 



Problem 

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 

If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1 Scenario #2:
impossible Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

大致题意:

给出一个国际棋盘的大小,推断马是否能不反复的走过全部格,并记录下当中按字典序排列的第一种路径。

代码例如以下:

#include <cstdio>
#include <cstring>
#define M 26
struct node
{
int x, y;
}w[M*M];
bool vis[M][M];
int p, q;
int flag = 0;
int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
//按此顺序搜索出来的结果就是字典序
bool judge(int x, int y)
{
if(x>=0&&x<q&&y>=0&&y<p&&!vis[x][y])
return true;
return false;
}
void dfs(int x, int y, int step)
{
w[step].x = x,w[step].y = y;
vis[x][y] = true;
if(step == p*q-1)
{
flag = 1;
return ;
}
for(int i = 0; i < 8; i++)
{
int dx = w[step].x+dir[i][0];
int dy = w[step].y+dir[i][1];
if(judge(dx,dy))
{
vis[dx][dy] = true;
dfs(dx,dy,step+1);
if(flag)//一但找到就退出搜索
return;
vis[dx][dy] = false;
}
}
return ;
}
void print()
{
for(int i = 0; i < p*q; i++)//列为字母,行为数字
{
printf("%c%d",w[i].x+'A',w[i].y+1);
}
printf("\n\n");
}
int main()
{
int t, i, j, cas = 0;
scanf("%d",&t);
while(t--)
{
memset(vis,false,sizeof(vis));
flag = 0;
scanf("%d%d",&p,&q);
for(i = 0; i < q; i++)//列
{
for(j = 0; j < p; j++)//行
{
dfs(i,j,0);
if(flag)
break;
}
if(flag)
break;
}
printf("Scenario #%d:\n",++cas);
if(flag)
print();
else
printf("impossible\n\n");
}
return 0;
}

最新文章

  1. WPF学习之路(十四)样式和模板
  2. JQ分页功能
  3. 指针数组 vs 数组指针
  4. Redis设计与实现-内部数据结构篇
  5. MySQL和OneSQL并行插入性能对比
  6. String Format for DateTime
  7. zoj 2723 Semi-Prime
  8. hdu 1198 Farm Irrigation
  9. MySQL查询指定时间的数据
  10. idmap_ad — Samba&#39;s idmap_ad Backend for Winbind《转载》
  11. JS如何判断IE和火狐与Chrome浏览器
  12. 一次rman恢复的实验
  13. C语言学习——C程序的运行机理
  14. 如果不知道MySQL当前使用配置文件(my.cnf)的路径的解决方法
  15. SE 2014 年4月21日(二)
  16. 上门洗车APP --- Androidclient开发 之 项目结构介绍
  17. Mysql 5.1的坑
  18. 对比Cassandra、 Mongodb、CouchDB、Redis、Riak、 Membase、Neo4j、HBase
  19. Excel 使用单元格的值 查询MySQL数据库并返回数据给相应的单元格
  20. javascript 操作节点的属性

热门文章

  1. hdu 3177 Crixalis&amp;#39;s Equipment
  2. 金蝶KIS标准版与金蝶K3的差别
  3. MVC发送邮件
  4. caffe-ssd使用预训练模型做目标检测
  5. hdoj--1201--18岁生日(模拟)
  6. 8.QList QMap QVariant
  7. 5.listview(QStringList QStringListModel)
  8. python中黏包现象
  9. 网易NAPM Andorid SDK实现原理--转
  10. 洛谷P3358 最长k可重区间集问题(费用流)