解题思路:给出n对点的关系,求构成多少个环,如果对于点x和点y,它们本身就有一堵墙,即为它们本身就相连,如果find(x)=find(y),说明它们的根节点相同,它们之间肯定有直接或间接的相连,即形成环

样例的示意图

共3个环

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 642    Accepted Submission(s): 371

Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 
Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 
Output
Output the maximum number of ACMers who will be awarded. One answer one line.
 
Sample Input
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 
Sample Output
3

#include<stdio.h>
#include<string.h>
int pre[10005],a[10005];
int find( int root)
{
if(root!=pre[root])
pre[root]=find(pre[root]);
return pre[root];
}
void unionroot( int root1,int root2)
{
int x,y;
x=find(root1);
y=find(root2);
if(x!=y)
pre[x]=y;
} int main()
{
int root1,root2,x,y,i,n,m,tmp;
while(scanf("%d %d",&n,&m)!=EOF)
{
tmp=0;
for(i=0;i<=10005;i++)
pre[i]=i;
while(m--)
{
scanf("%d %d",&root1,&root2);
x=find(root1);
y=find(root2);
if(x==y)
tmp++;
unionroot(x,y);
} printf("%d\n",tmp); }
}

  

最新文章

  1. CCS5.2/CCS5.3/CCS5.4 仿真调试小技巧
  2. CSS 布局入门
  3. 腾讯TOS
  4. ASP.NET中的指令:
  5. m个苹果放在n个筐里,每个筐至少一个,所有的筐都一样,有多少种放法
  6. Reward(拓扑排序)
  7. 常用文件的文件头(附JAVA测试类)
  8. hdu 4790 Just Random (思路+分类计算+数学)
  9. AndroidUI 引导页面的使用
  10. 《JS权威指南学习总结--第四章4.9.1相等和严格相等》
  11. Everything 使用记录
  12. Qt 给控件QLineEdit添加clicked事件方法
  13. Android应用程序国际化
  14. 010_动态语言与鸭子类型及python2和3的区别
  15. Nginx 学习笔记(九)申请Let&#39;s Encrypt通配符HTTPS证书
  16. From CORBA technology To Thrift technology
  17. 图-&gt;存储结构-&gt;邻接多重表
  18. python 部分函数
  19. HashMap的长度为什么要是2的n次方
  20. js里常用函数之高阶函数

热门文章

  1. 源码编译Oprofile
  2. Win7 disk.sys无法加载的问题
  3. CREC 2017
  4. jquery的animate能渐变background-color
  5. 相对URL:协议名跨域的一种处理方式
  6. NOI 2011 阿狸的打字机 (AC自动机+dfs序+树状数组)
  7. [luogu]P4365[九省联考]秘密袭击coat(非官方正解)
  8. Unity的Json解析&lt;一&gt;--读取Json文件
  9. javascript try{}catch(e){}
  10. angular-Then的用法