Description

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture,
but fighting skill is also taken into account. 

When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose
fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his. 

The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him. 
 

Input

There are several test cases. 

In each test case: 

The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000) 

The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first. 

The input ends with n = 0. 
 

Output

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old
monk's id.
 

Sample Input

3
2 1
3 3
4 2
0
 

Sample Output

2 1
3 2
4 2

大致题意:非常久曾经。少林寺里仅仅有一个等级10^9为方丈,他编号为1,少林寺里有个规矩,每一个新来的和尚都必须和一位等级最接近自己的老(就是比他先来的)和尚进行战斗。后来又来了n个和尚。而且他们按入寺时间依次编号2~n+1,可是时间太久。方丈已经不知道每一个和尚来的时候是跟哪个和尚战斗了,可是他还是记得哪个和尚比哪个和尚先来的。

输入给出n个和尚的编号和他们的等级。

以下就靠你了,让你依次求出每一个和尚进寺是是跟谁战斗的,并输出。

解题思路:直接开数组的话,每次找跟他等级最接近的肯定要排序。眼下知道的最快的快排的也是O(n*lg n)的,因为数据给的是10^5,再加上还要操作,时间已经超了。

所以,得换个思路,那就得用到STL中的map的优势了,也好久没用map做题了。map里的数据会自己主动按键值升序排列。据说map内部的排序是用红黑树(一种不明觉厉的数据结构)实现的。其时间复杂度是O(n)的。同一时候,map里还能够直接用find()按键值查找键值所在的迭代器,这就太方便了。

详细实现步骤:1.先开个map<int, int> monk,  把方丈的编号id和等级grad在map里建立映射。这里用到了一个小细节。

建立映射能够直接这样写。monk[grad] = id.

2.在循环输入n个和尚的信息,

1)每次输入一个和尚的信息。然后在map里建立映射;

2)此时用find(grad)寻找当前增加的和尚所在的迭代器。

3)然后,考虑当前的迭代器的位置,若是最后一个。就直接输出当前迭代器的前一个;

要是第一个。就输出当前迭代器的后面一个;

要既不是第一个也不是最后一个的话。就比較当前迭代器的first和它前后两迭代器first之间的差值哪个更小,小的输出;

要是两差值一样的话,输出前一个迭代器。

AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
#define INF 0x7fffffff map<int, int> a; //声明一个map对象 int main()
{
#ifdef sxk
freopen("in.txt","r",stdin);
#endif
int n, k, g;
while(scanf("%d",&n)!=EOF && n)
{
a[1e9] = 1; //处理方丈
for(int i=0; i<n; i++){
scanf("%d%d", &k, &g);
a[g] = k;
map<int, int>::iterator temp = a.find(g); //按grad查找当前和尚所在的迭代器
if(temp == a.begin()) printf("%d %d\n", k, (++temp)->second);
else if(temp == a.end()) printf("%d %d\n", k, (--temp)->second);
else{
if(abs((--temp)->first - (++temp)->first) > abs((++temp)->first - (--temp)->first))
printf("%d %d\n", k, (++temp)->second);
else printf("%d %d\n", k, (--temp)->second);
}
}
a.clear();
}
return 0;
}

最新文章

  1. OpenCV2:图像的几何变换,平移、镜像、缩放、旋转(2)
  2. 向通知栏发送通知点击跳转并传递数据(PendingIntent)传递数据
  3. 再谈collections模块defaultdict()和namedtuple()
  4. linux内核中jiffies的回绕问题【转】
  5. C118 免按开机自动加载固件
  6. Excel导出-Epplus
  7. 【原创】ZeroClipboard的时代或许已经过去了
  8. [转] C++临时变量的生命周期
  9. Guava API学习之Preconditions优雅的检验参数 编辑
  10. cf492E Vanya and Field
  11. eclipse 创建maven 项目 动态web工程报错
  12. IT小团队的管理者的突围之道
  13. git 命令详细
  14. 常用的tcpdump操作
  15. Win10安装Ubuntu子系统教程(附安装图形化界面)
  16. 我今天遇到的条件语句Integer类型的
  17. wind量化交易
  18. 剑指offer编程题Java实现——面试题4后的相关题目
  19. Asp.Net Core发布绑定域名和端口
  20. html5 canvas实现图片玻璃碎片特效

热门文章

  1. 《你又怎么了我错了行了吧》【Beta】Scrum Meeting 2
  2. STM32 关于头文件路径没添加错误问题(cannot open source input file &quot;spi.h&quot;: No such file or directory)
  3. 记一次在广播(BroadcastReceiver)或服务(Service)里弹窗的“完美”实践
  4. error: could not install *smartsocket* listener: Address already in use 下午8:49 ADB server didn&#39;t ACK 下午8:49 * failed to start daemon * 下午8:49 error: cannot connect to daemon
  5. POJ 3749
  6. 【转载】tslib移植_freescale imx6
  7. sqlplus登录提示:ORA-12162:TNS:net service name is incorrectly specified错误
  8. 关于Javakeywordsynchronized——单例模式的思考
  9. Git 时间,将代码托管到GitHub 上
  10. HttpClient get和HttpClient Post请求的方式获取服务器的返回数据