Hailstone HOTPO

Time Limit: 2000/1000ms (Java/Others)

Problem Description:

The hailstone sequence is formed in the following way:
(1) If n is even, divide it by 2 to get n'
(2) If n is odd, multiply it by 3 and add 1 to get n'
It is conjectured that for any positive integer number n, the sequence will always end in the repeating cycle: 4, 2, 1, 4, 2, 1,... Suffice to say , when n == 1, we will say the sequence has ended.
Write a program to determine the largest value in the sequence for a given n.
译文:以下面的方式形成在冰雹序列:
(1)如果n为偶数,除以2以获得N“
(2)如果n为奇数,乘以3,并添加1以获得N”
据推测,对于任何正整数n,序列将总是以重复周期结束:4,2,1,4,2,1,......只要n == 1,我们就会说序列已经结束。
编写一个程序来确定给定n的序列中的最大值。

Input:

The first line of input contains a single integer P, (1<= P <= 100000), which is the number of data set s that follow. Each data set should be processed identically and independently.
Each data set consists of a single line of input consisting of two space separated decimal integers. The first integer is the data set number. The second integer is n, (1 <= n <= 100,000), which is the starting value.
译文:第一行输入包含一个整数P,(1 <= P <= 100000),它是后面的数据集的数量。每个数据集应该被相同和独立地处理。
每个数据集由一个由两个空格分隔的十进制整数组成的单行输入组成。第一个整数是数据集编号。第二个整数是n,(1 <= n <= 100,000),这是起始值。

Output:

For each data set there is a single line of output consisting of the data set number, a single space, and the largest value in the sequence starting at and including n. 
译文:对于每个数据集,都有一行输出,其中包含数据集编号,单个空间以及从n开始的序列中的最大值。

Sample Input:

4
1 1
2 3
3 9999
4 100000

Sample Output:

1 1
2 16
3 101248
4 100000
解题思路:题目很简单,就是找序列中的最大值,按规则来查找。我们知道序列中要么是奇数要么是偶数,因而在循环中判断一下是否为奇数,若是,执行规则(2)后也是变为偶数,所以容易想到循环体内最后直接执行n/=2;加上查找序列中最大值的判断语句,水过。说明:题目中输入的个数p最多就有10^5个,假设有p个n是接近10^5,那么求序列中的最大值可能就会超时,因为循环节长度是不知道的,有可能更多的循环次数,所以后台数据有点水,这题真正的解法应该不是这样的,让菜鸡想想,待想到再回来修改!
贴一下水数据的AC代码:
 #include<bits/stdc++.h>
using namespace std;
int main()
{
int p,m,n,maxn;
cin>>p;
while(p--){
cin>>m>>n;
maxn=n;
while(n!=){
if(n%)n=n*+;
if(maxn<n)maxn=n;
n/=;
}
cout<<m<<' '<<maxn<<endl;
}
return ;
}

杭电hdu4484与此题一样,题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4484

最新文章

  1. 在.NET Core控制台程序中使用依赖注入
  2. FizzBuzzWhizz游戏的高效解法
  3. git使用札记
  4. 在 MAC OS X 安装 ADB (Android调试桥)
  5. [转载]iOS Provisioning Profile(Certificate)与Code Signing详解
  6. poj 1562 Oil Deposits (广搜,简单)
  7. CSS中nth-child和nth-of-type的简单使用
  8. (一)学习CSS之z-index属性
  9. JSP ---- 声明、表达式、脚本、注释
  10. Windows Azure入门教学系列 (六):使用Table Storage
  11. [渣译文] SignalR 2.0 系列: 支持的平台
  12. 移动端布局,C3新增属性
  13. python 可迭代对象 迭代器 生成器总结
  14. LeetCode(103): 二叉树的锯齿形层次遍历
  15. 涂抹mysql笔记-mysql性能调优和诊断
  16. strcpy函数用法
  17. ABP Quartz 作业调度第三篇
  18. SELECT版FTP
  19. Linux写时拷贝技术【转】
  20. pthread_exit pthread_join

热门文章

  1. 洛谷 U41571 Agent2
  2. Windows7下ftp服务器
  3. jquery校验框架
  4. DELPHI、FLASH、AS3、FLEX使用Protobuf(google Protocol Buffers)的具体方法
  5. SaltStack学习系列之state常用模块
  6. Linux挂载新盘
  7. web常见之音乐播放器
  8. HDU 4352 XHXJ&amp;#39;s LIS(数位dp&amp;amp;状态压缩)
  9. SpringMVC学习指南-前言
  10. Oracle新建数据库