Beautiful People


Time Limit: 5 Seconds      Memory Limit: 32768 KB      Special Judge


The most prestigious sports club in one city has exactly N members. Each of its members is strong and beautiful. More precisely, i-th member of this club (members being numbered by the
time they entered the club) has strength Si and beauty Bi. Since this is a very prestigious club, its members are very rich and therefore extraordinary people, so they often extremely hate each other. Strictly speaking, i-th member of
the club Mr X hates j-th member of the club Mr Y if Si <= Sj and Bi >= Bj or if Si >= Sj and Bi <= Bj (if both properties of Mr X are greater then corresponding properties
of Mr Y, he doesn��t even notice him, on the other hand, if both of his properties are less, he respects Mr Y very much).

To celebrate a new 2005 year, the administration of the club is planning to organize a party. However they are afraid that if two people who hate each other would simultaneouly attend
the party, after a drink or two they would start a fight. So no two people who hate each other should be invited. On the other hand, to keep the club prestige at the apropriate level, administration wants to invite as many people as possible.

Being the only one among administration who is not afraid of touching a computer, you are to write a program which would find out whom to invite to the party.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank
line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

The first line of the input file contains integer N - the number of members of the club. (2 <= N <= 100 000). Next N lines contain two numbers each - Si and Bi respectively
(1 <= Si, Bi <= 109).

Output

On the first line of the output file print the maximum number of the people that can be invited to the party. On the second line output N integers - numbers of members to be invited in
arbitrary order. If several solutions exist, output any one.

Sample Input

1



4

1 1

1 2

2 1

2 2

Sample Output

2

1 4

题意:有n个人,每一个人有一个Si和Bi,假设Si < Sj && Bi < Bj。则 i 和 j 不互相讨厌。问从这n个人中最多能够选出多少个人使得随意两个人都不会互相讨厌。

分析:由于一个人的S和B都严格小于另外一个人的S和B时,这连个人才不会互相讨厌。所以能够先对S从小到大排序,假设S同样则把B从大到小排序,这样问题就转化为了求最长上升子序列。当S同样时之所以要对B从大到小排序,是由于假设S递增的话,那么选出的方案中会将S同样的几个人都包括进去。不符合题目要求。然后就用O(nlogn)的算法求最长上升子序列的同一时候。记录到达每个数时的最大长度。最后从最大长度向下输出路径就可以。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std; const int N = 100005;
int dp[N]; //dp[i]表示最长上升子序列长度为i时子序列末尾的最小B值
int mark[N]; //mark[i]表示以第i个people结尾的最长上升子序列的长度
struct Member {
int s, b;
int id;
bool operator < (const Member &x) const {
if(s == x.s) return x.b < b;
return s < x.s;
}
} a[N]; int main() {
int n;
while(~scanf("%d", &n)) {
for(int i = 1; i <= n; i++) {
scanf("%d%d", &a[i].s, &a[i].b);
a[i].id = i;
}
sort(a+1, a+n+1);
int max_len = 0;
dp[++max_len] = a[1].b;
mark[1] = max_len;
for(int i = 2; i <= n; i++) {
if(dp[max_len] < a[i].b) {
dp[++max_len] = a[i].b;
mark[i] = max_len;
}
else {
int k = lower_bound(dp+1, dp+1+max_len, a[i].b) - dp;
dp[k] = a[i].b;
mark[i] = k;
}
}
printf("%d\n", max_len);
for(int i = n; i >= 1; i--) {
if(mark[i] == max_len) {
printf("%d", a[i].id);
if(max_len > 1) printf(" ");
max_len--;
}
}
printf("\n");
}
return 0;
}

版权声明:本文博客原创文章,博客,未经同意,不得转载。

最新文章

  1. JSP内置对象---request对象(用户登录页面(setAttribute))
  2. sudo 使用不了, the permissions on the /etc/sudoers file are changed to something other than 0440
  3. poj-----(2828)Buy Tickets(线段树单点更新)
  4. jQuery生成全页面的悬浮覆盖层效果(overlay)
  5. C#构造函数使用
  6. Android4大组件
  7. Bootstrap插件——(Tab)标签页
  8. MATLAB描绘极坐标图像——polar
  9. 使用CoApp创建NuGet C++静态库包
  10. django之admin流程
  11. Unity项目导入的error
  12. Genymotion下载及安装
  13. CSS中的px与物理像素、逻辑像素、1px边框问题
  14. Netty实战八之引导
  15. Redis教程(Windows)
  16. ROW_NUMBER() OVER(PARTITION BY COLUMN ORDER BY COLUMN)
  17. 利用Springboot-mail发送邮件
  18. 9.1 翻译系列:数据注解特性之----Table【EF 6 Code-First 系列】
  19. super and this
  20. swift 约束 - SnapKit 适配iPhoneX 安全区 和苹果自带的VFL ,auto layout 安全区适配

热门文章

  1. 解决gvim 8.1中zip插件打开zip文件内容时,而文件路径带有空格的问题。
  2. 中小研发团队架构实践之分布式协调器.Net版ZooKeeper
  3. 简要分析武汉一起好P2P平台的核心功能
  4. js课程 1-5 js如何测试变量的数据类型
  5. 五一巨献,问答有礼,105QB送给IT互联网界的劳动人民
  6. Java NIO学习笔记之基本概念
  7. [React Router v4] Render Nested Routes
  8. [React Router v4] Parse Query Parameters
  9. python启动应用程序和终止应用程序
  10. qt-4.8.4安装和环境变量配置