hide handkerchief

Problem Description

The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.

Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .

Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.

So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".

Input

There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.

Output

For each input case, you should only the result that Haha can find the handkerchief or not.

Sample Input

3 2

-1 -1

Sample Output

YES

Source

HDU 2007-6 Programming Contest

Recommend

xhd

正确代码

	#include <cstdio>
#include <iostream>
using namespace std;
int gcd(int a,int b)
{
int c=a%b;
return c==0?b:gcd(b,c);
}
int main()
{
long long n,m;
while(cin>>n>>m)
{
if(n==-1&&m==-1)
break;
if(gcd(n,m)==1)
cout<<"YES"<<endl;
else
cout<<"POOR Haha"<<endl;
}
}

题意理解

较为简单的遍历算法题,问题的关键在于怎么判断不断跳过m-1次盒子是否可以遍历到所有n个盒子。当盒子的数量n与跳过盒子的数量m-1互为质数时,则能遍历所有盒子,若n与m-1有除1以外其他最大公约数时,haha就会回到起点重复之前的动作从而导致无法遍历所有盒子。

最新文章

  1. java 聊天猜拳机器人
  2. javascript设计模式实践之模板方法--具有百叶窗切换图片效果的JQuery插件(二)
  3. org.hibernate.NonUniqueObjectException: a different object with the same identifier value was alread---------程序报错
  4. asp.net_MVC_jq三级联动
  5. VS2010中水晶报表应用及实例
  6. 关于PowerShell中的命令的别名
  7. composite template 组合模式
  8. dns服务搭建
  9. c#读取并分析sql Server2005数据库日志
  10. 【Java】List遍历时删除元素的正确方式
  11. Python学习笔记_1
  12. day02 python数据类型
  13. [leetcode]49. Group Anagrams变位词归类
  14. 提高Linux运维效率的30个命令行常用快捷键
  15. Docker学习笔记之Docker的Build 原理
  16. C#动态显示时间
  17. ListPopupWindow 列表弹窗 常见弹窗区别
  18. 解决Java“syntax error on token enum”问题
  19. python练习1--用户登入
  20. Spring MVC学习之三:处理方法返回值的可选类型

热门文章

  1. 大学课后答案微信小程序项目实践(1)
  2. vue环境搭建及创建项目
  3. Django:Python3.6.2+Django2.0配置MySQL 转载
  4. Linux环境变量$PATH
  5. gitlab(7.9)升级到8.0.1
  6. selenium 全天课整理(二)
  7. js在点击的按钮下面弹框
  8. machine learning (6)---how to choose features, polynomial regression
  9. PHP——最新号码归属地数据库
  10. PHP一个for循环输出9*9乘法表