Shift Dot

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

给出平面直角坐标系中的一点,并顺序给出n个向量,求该点根据给定的n个向量位移后的位置。

Input

多组输入,第一行是三个整数x,y,n,表示点的坐标(x,y),和向量的个数n。接下来n行,每行两个数xi,yi,表示第i个向量。题目中所有数据不会超出整形范围。

Output

每组输入输出一行,"(x,y)"表示点的最终位置。

Sample Input

0 0 1

2 3

0 0 2

1 2

2 3

Sample Output

(2,3)

(3,5)

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
point a,b;
int n,i;
while(cin.hasNext())
{
a = new point(cin.nextInt(),cin.nextInt());
n = cin.nextInt();
for(i=0;i<n;i++)
{
b = new point(cin.nextInt(),cin.nextInt());
a.sum(b);
}
System.out.printf("(%d,%d)\n",a.x,a.y);
}
cin.close();
}
} class point
{
int x,y;
point(int x,int y)
{
this.x = x;
this.y = y;
}
void sum(point p)
{
this.x += p.x;
this.y += p.y;
}
}

最新文章

  1. how-to-redirect-cin-and-cout-to-files
  2. No goals have been specified for this build
  3. Canvas学习
  4. NSOperation基本使用
  5. 制作Win7(x86)PE ISO文件
  6. Jquery LigerUI框架学习(一)
  7. 2014年度辛星css教程夏季版第三节
  8. Linux经常使用命令大全
  9. uva11922(强行用rope替代spaly)
  10. 【白痴弟弟和你加强应用层】阅读 Develop API Guides 思考(一个)
  11. FBO
  12. C#版 - Leetcode 13. 罗马数字转整数 - 题解
  13. BZOJ1688|二进制枚举子集| 状态压缩DP
  14. (转)hdu 3436Queue-jumpers--splay+离散化
  15. 09-伪数组 arguments
  16. 信息列表中的ContentObserver、CONTENT_URI等
  17. 解决:According to TLD or attribute directive in tag file, attribute value does not accept any express。
  18. 一段基于Redis-SortedSet的限流代码
  19. c语言:矩阵相乘-矩阵相加 新手练习1
  20. GetTop(),GetTopLeft()等等

热门文章

  1. gulp入门之常见处理方式(三)
  2. python-基础-面象对象
  3. chgrp权限命令
  4. hdu1233还是畅通工程
  5. mac下更改MySQL的默认编码
  6. 零开始Android逆向教程(一)——初探Android逆向
  7. Java问题解读系列之String相关---String类为什么是final的?
  8. NKOJ3485 【2015多校联训4】数据
  9. Javascript-正则表达式常用字符集及方法
  10. 编译libusb库