1098: The 3n + 1 problem

时间限制: 1 Sec  内存限制: 64 MB

提交: 368  解决: 148

题目描述

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence
of numbers will be generated for n = 22: 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1, 000,
000. For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between
i and j, including both endpoints.

输入

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

输出

For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers
on one line and with one line of output for each line of input.

样例输入

1 10
100 200
201 210
900 1000

样例输出

1 10 20
100 200 125
201 210 89
900 1000 174
总是望着曾经的空间发呆,那些说好不分开的朋友不在了,转身,陌路。 熟悉的,安静了, 安静的,离开了, 离开的,陌生了, 陌生的,消失了, 消失的,陌路了。

#include <stdio.h>
#include <stdlib.h>
int main()
{
int a,b,i,j=0,m=0,c=0;
for(; ~scanf("%d%d",&a,&b); m=0)
{
for(c=a>b?b:a; c<=(a>b?a:b); c++)
{
i=c,j=0;
for(; i!=1; j++)
if(i%2==0)i/=2;
else i=i*3+1;
m=j>m?j:m;
}
printf("%d %d %d\n",a,b,m+1);
}
return 0;
}

最新文章

  1. jQuery 事件探秘
  2. mysql备份方法
  3. DB2时间操作
  4. smarty 常用参数
  5. shell全备份脚本(借鉴别人的,在其基础上修复完善了bug)
  6. 结构-行为-样式-Js排序算法之 快速排序
  7. animate动画被锁在队列中不动怎么解决
  8. 洛谷 [P2765] 魔术球问题
  9. 1、react-native中expo的真机测试字体不加载的坑
  10. Oracle中的位图索引和函数索引
  11. qt设计器中使用自定义控件
  12. 使用JavaScript实现表现和数据分离
  13. 解决linux系统CentOS下调整home和根分区大小
  14. opencv 显示摄像头数据
  15. css 下边框
  16. 论文笔记——MobileNets(Efficient Convolutional Neural Networks for Mobile Vision Applications)
  17. FIO测试磁盘的iops
  18. 审计系统---堡垒机项目之用户交互+session日志写入数据库[完整版]
  19. RSS是什么,RSS怎么玩,RSS原理是什么 (zhuan)
  20. Scrapy学习篇(三)之创建项目

热门文章

  1. JavaScript中变量、作用域和内存问题(JavaScript高级程序设计第4章)
  2. Tomcat 7.0.3x 启动慢并且遇到StackOverflowError的异常的解决办法
  3. 关于 HTTP meta 的 IE=edge 说明
  4. Problem 2125 简单的等式(FZU),,数学题。。。
  5. Codeforces 892 B.Wrath
  6. 【Java源码】集合类-优先队列PriorityQueue
  7. win10 笔记本猎豹WiFi无法打开
  8. mysql查看存储过程show procedure status;
  9. GO语言 --socket.io
  10. 【APUE】信号量、互斥体和自旋锁