Minimum’s Revenge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1409    Accepted Submission(s): 749


Problem Description
There is a graph of n vertices which are indexed from 1 to n. For any pair of different vertices, the weight of the edge between them is the least common multiple of their indexes.

Mr. Frog is wondering about the total weight of the minimum spanning tree. Can you help him?
 

Input
The first line contains only one integer T (T≤100),
which indicates the number of test cases.

For each test case, the first line contains only one integer n (2≤n≤109),
indicating the number of vertices.
 

Output
For each test case, output one line "Case #x:y",where x is the case number (starting from 1) and y is the total weight of the minimum spanning tree.
 

Sample Input

2
2
3
 

Sample Output

Case #1: 2
Case #2: 5

Hint

In the second sample, the graph contains 3 edges which are (1, 2, 2), (1, 3, 3) and (2, 3, 6). Thus the answer is 5.

 

Source

思路:水题,注意变量类型设为long long

#include <iostream>
#include<stdio.h>
using namespace std; int main()
{
int t;
scanf("%d",&t);
long long n;
int path=1;
while(t--)
{
scanf("%lld",&n);
long long sum=0;
sum=((2+n)*(n-1))/2;
printf("Case #%d: %lld\n",path++,sum);
}
return 0;
}

最新文章

  1. 跨域之jsonp
  2. JavaScript toUpperCase() 方法和 toLowerCase() 方法
  3. 关于Dijkstra最短路径算法
  4. ACM题目————数素数
  5. SPL 全面剖析
  6. ListView Web 服务器控件概述(MSDN)
  7. Chapter 15_4 子模块和包
  8. Codeforces Round #530 (Div. 2) C D
  9. NGUI_创建图集Altas
  10. Django框架(九) Django之ORM常用字段和参数
  11. MTD应用学习札记【转】
  12. 000 关于IDEA的基本环境配置以及快速使用(git拉载程序,Jdk安装,tomcat部署,应用程序打包运行)
  13. CNN卷积可视化与反卷积
  14. [UE4]动画序列面板
  15. poj1251 Jungle Roads(Prime || Kruskal)
  16. 解决linux分区提示doesn&#39;t contain a valid partition table
  17. 鼠标聚焦到Input输入框时,按回车键刷新页面原因及解决方法
  18. 算法笔记_023:拓扑排序(Java)
  19. 什么是JSONP?
  20. Xshell中使用FTP/SFTP工具下载文件

热门文章

  1. 2017-10-02-morning
  2. codevs——1006 等差数列
  3. 使用异步委托执行线程(delegate)
  4. Oracle SqlPlus导出查询结果
  5. 【Nginx】负载均衡-加权轮询策略剖析
  6. 总结react中遇到的坑和一些小的知识点
  7. 基于cocos2d-x的跑酷游戏,不同高度地面的碰撞检測demo,有兴趣能够看一看
  8. Mac OS X 10.10, Eclipse+ADT真机调试代码时,Device Chooser中不显示真机的解决方式
  9. docker init 起步
  10. Java千百问_03基本的语法(001)_局部变量、类变量、实例变量有什么差别