How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 1045    Accepted Submission(s): 362

Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them
is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.



Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children
enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who
has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between
A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school.
Of course, all helpers including the schoolmaster are paid by Boss Liu.



You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you
want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 
Input
There are several test cases.



For each test case:



The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30,
3 <= M <= 1000)



Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.



The input ends with N = 0 and M = 0.



It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 
Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 
Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0
 
Sample Output
50
Inf
 
最短路径问题,输出最短路径中最长的路径,此题弗洛伊德似乎无解:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 0x3f3f3f3f
using namespace std;
int map[1100][1100],m,n,dis[1100],vis[1100];
void init()
{
memset(map,N,sizeof(map));
int a,b,c;
for(int j=1;j<=n;j++)
{
scanf("%d%d%d",&a,&b,&c);
if(map[a][b]>c)
map[a][b]=map[b][a]=c;
}
}
void dj(int x)
{
for(int j=1;j<=m;j++)
{
dis[j]=map[x][j];
}
dis[x]=0;
vis[x]=1;
int min,k;
for(int i=0;i<m;i++)
{
min=N;
for(int j=1;j<=m;j++)
{
if(!vis[j]&&dis[j]<min)
{
min=dis[j];
k=j;
}
}
if(min==N)
break;
vis[k]=1;
for(int j=1;j<=m;j++)
{
if(!vis[j]&&dis[j]>dis[k]+map[k][j])
dis[j]=dis[k]+map[k][j];
}
}
}
int main()
{
int i,j,k,l,x,y,z;
while(scanf("%d%d",&m,&n)&&(m||n))
{
init();
int min=0;
for(int i=2;i<=m-1;i++)
{
memset(vis,0,sizeof(vis));
vis[i]=1;
dj(1);
min=min>dis[m]? min:dis[m];
}
if(min==N)
printf("Inf\n");
else
printf("%d\n",min);
}
return 0;
}

最新文章

  1. Lintcode 97.二叉树的最大深度
  2. hive中分号问题
  3. CA Loves GCD (BC#78 1002) (hdu 5656)
  4. Unity3D 面试题汇总
  5. python pip 升级每个包
  6. Dom之表单提交与默认行为
  7. Android实例-处理隐藏输入法后不再显示问题(XE8+小米2)
  8. Html----常见标签
  9. codevs 1994 排队 排列组合+高精度
  10. 弹出层easydialog-v2.0
  11. Linux - Bash shell的功能;内建命令type
  12. Python_csv电子表格
  13. spring相关面试题
  14. 管道流_PipedInputStream与PipedOutputStream
  15. JSON平铺功能的实现(JS操作JSON数据)
  16. shell 5参数
  17. 【354】Numpy 相关函数应用
  18. Axure 8.0.0.3312下载地址以及注册码
  19. 【转载】delphi下如何复制文件
  20. MCP|XN|Decreased Antibiotic Susceptibility Driven by Global Remodeling of the Klebsiella pneumoniae Proteome(肺炎杆菌通过整体重构蛋白质组降低抗生素敏感性)

热门文章

  1. Android 进程常驻(0)----MarsDaemon使用说明
  2. poj--1703--Find them, Catch them(并查集巧用)
  3. django 笔记8 url模板 自定义函数 simple_tag
  4. Linux环境下源码安装PostgreSQL
  5. ReactiveCocoa 中 RACSignal 是如何发送信号的
  6. node使用express命令报错找不到ejs的解决方法
  7. 「BZOJ3343」教主的魔法(分块+二分查找)
  8. POJ2104 K-th Number(整体二分)
  9. 为什么使用Nginx &amp; Nginx的使用
  10. 【Henu ACM Round#17 F】Upgrading Array