Hangman Judge 

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic
game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.
       ______
    | |
    | O
    | /|\
    | |
    | / \
    __|_
    | |______
    |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the
game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.

一个字符串的游戏  有一个你不知道的字符串  你開始有7条命  然后你每次猜一个字母  若你猜的字母在原字符串中  原字符串就去掉全部那个字母  否则你失去一条命   假设你在命耗完之前原字符串中全部的字母都被猜出  则你赢   假设你在命耗完了原字符串中还有字母没被猜出  则你输    假设你在命没耗完原字符串中也还有字母没被猜出  视为你放弃

给你还有一个字符串作为你猜的顺序  推断你能否赢:

//UVa489 Hangman
#include<cstdio>
#include<cstring>
using namespace std;
const int N = 1000;
char a[N], b[N];
int cas, la, lb, i, j;
int main()
{
while (scanf ("%d", &cas), cas + 1)
{
scanf ("%s %s", a, b);
la = strlen (a);
lb = strlen (b);
int ca[26] = {0}, left = 7;
for (i = 0; i < la; ++i)
++ca[a[i] - 'a'];
for (i = 0; i < lb; ++i)
if (ca[b[i] - 'a'] != 0)
{
ca[b[i] - 'a'] = 0;
for (j = 0; j < 26; ++j)
if (ca[j] != 0) break;
if (j == 26)
{
printf ("Round %d\nYou win.\n", cas);
break;
}
}
else if (--left == 0)
{
printf ("Round %d\nYou lose.\n", cas);
break;
}
if (i == lb) printf ("Round %d\nYou chickened out.\n", cas);
}
return 0;
}

最新文章

  1. List 泛型 集合中 Find 的用法
  2. JavaSript模块规范 - AMD规范与CMD规范介绍 (转载lovenyf.blog.chinaunix.net)
  3. GitHub使用简单记录
  4. web双机热备添加心跳检测ip的时候填了网关导致外网ip不能上网
  5. C# 3.0 特性之扩展方法
  6. Flask学习记录之Flask-SQLAlchemy
  7. lighttpd配置虚拟主机/php等WEB环境
  8. JavaScript高级程序设计:第五章
  9. 零基础HTML编码学习笔记
  10. windows7 桌面突然卡住了,点击右键点不了,点击桌面软件点不了,怎么办?
  11. SpringMVC入门(基于注解方式实现)
  12. Python 自学积累(一)
  13. redis安装和简介(1)
  14. 洛谷 P2272 [ZJOI2007]最大半连通子图 解题报告
  15. python--flask框架的安装和简单使用(转)
  16. 我的Android进阶之旅】GitHub 上排名前 100 的 Android 开源库进行简单的介绍
  17. ReactNative安装配置
  18. spring配置加载2次实例问题。
  19. UOJ78 二分图最大匹配
  20. a REST API

热门文章

  1. android调用webservice接口获取信息
  2. dedecms手机网站内页上一篇/下一篇的翻页功能
  3. vue学习图解
  4. Python-Day07-图形用户界面和游戏开发
  5. java项目其他基础配置
  6. offset 后 指针数组转换
  7. windows服务器修改远程登录的端口+防火墙配置
  8. .Net Core2.2 + EF Core + DI,三层框架项目搭建教程
  9. libevent reference Mannual II--library
  10. unity问题笔记