Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16032    Accepted Submission(s): 5441

Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.



For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents
with the above coins. Note that we count that there is one way of making change for zero cent.



Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 
Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 
Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 
Sample Input
11
26
 
Sample Output
4
13
 
Author
Lily

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[500][600];
int num[1000];
int coin[6]={0,1,5,10,25,50};
void getnum()
{
memset(dp,0,sizeof(dp));
memset(num,0,sizeof(num));
dp[0][0]=1;
for(int i=1;i<=5;i++)
{
for(int j=0;j<=250;j++)//货币总面额不超过250
{
for(int k=0;k<100;k++)//硬币总数不超过100个
{
if(coin[i]+j<=250)
dp[coin[i]+j][k+1]+=dp[j][k];//当前货币总面值为j,分成k个硬币
else
break;
}
}
}
for(int i=0;i<=250;i++)
{
for(int j=0;j<=100;j++)
num[i]+=dp[i][j];
}
}
int main()
{
int n;
getnum();
while(scanf("%d",&n)!=EOF)
{
printf("%d\n",num[n]);
}
}

最新文章

  1. iOS学习笔记——滚动视图(scrollView)
  2. Java 2D API - 2. Graphics 入门
  3. 《BI项目笔记》挑选产出分析Cube
  4. Mina、Netty、Twisted一起学(一):实现简单的TCP服务器
  5. 如何将DJANGO轻量级化
  6. Android 国际化字符串资源,各语言目录表及从字符串资源文件读字符方法
  7. goodAddr
  8. 安卓Activity组件
  9. NABCD原则
  10. python基础15上_迭代器_生成器
  11. dedecms中arclist标签做分页以及分页点击模块样式错乱问题
  12. 如何解决ORA-28002 the password will expire within 7 days问题(密码快过期)
  13. PHP语言的优缺点
  14. Luogu1081 NOIP2012 开车旅行 倍增
  15. php字符串截取
  16. 吴裕雄 16-MySQL UNION 操作符
  17. 数学:二次剩余与n次剩余
  18. Msys2:windows下好用的unix模拟器
  19. Currency Exchange---poj1860 ( spfa, 回路,最长路)
  20. Docker数据卷和Docker系统管理(二)

热门文章

  1. Map初始化
  2. Android拍照,录制视频,相机简单功能实现
  3. 编写jQuery 插件
  4. (转)RabbitMQ学习之安装
  5. php 的多进程
  6. bzoj 1191: [HNOI2006]超级英雄Hero 网络流_残量网络
  7. 基于BootStrap,FortAweSome,Ajax的学生管理系统
  8. 封装自己的jquery框架
  9. 洛谷P1909 买铅笔
  10. ZOJ 3874 Permutation Graph (分治NTT优化DP)