题目链接:

problemId=5383">http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5383

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression
follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there
are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix
expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence
which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations
to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

Author: CHEN, Cong

题意:

给出两个操作:插入和随意交换字符串两个字母;

求最少的操作数使得字符串变成后缀表达式,

PS:

仅仅有缺少数字的时候才会用到插入,其它就是交换操作,把*都交换到后面。而一个*须要两个数字。

代码例如以下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 2017;
int main()
{
int t;
char s[maxn];
scanf("%d",&t);
while(t--)
{
scanf("%s",s);
int len = strlen(s);
int cont_num = 0, cont_star = 0;
for(int i = 0; i < len; i++)
{
if(s[i] == '*')
cont_star++;
else
cont_num++;
}
if(len == cont_num)
{
printf("0\n");
continue;
}
int k = cont_star-cont_num+1;
if(k < 0)
k = 0;
int star = 0;
int num = k;
int ans = k;
int re[maxn];
for(int i = len-1, l = 0; i >= 0; i--)
{
if(s[i]!='*')
re[l++] = i;
}
int l = 0;
for(int i = 0; i < len; i++)
{
if(s[i]=='*')
star++;
else
num++;
if(star+1 > num)
{
swap(s[i],s[re[l++]]);
ans++;
star--;
num++;
}
}
if(s[len-1] != '*')
ans++;
printf("%d\n",ans);
}
return 0;
}

最新文章

  1. .dtsi .dts dtc dtb 是什么
  2. C++强制类型转换操作符 static_cast
  3. [CentOs]ip操作
  4. 时间和日期控件(Calendar1)
  5. iOS 实现快速切换主题详细教程(附上源码)
  6. yum与rpm的使用
  7. 自己实现FormsAuthentication.SetAuthCookie方法,怎样在ASP.NET服务端代码中删除客户端Cookie
  8. hdu5443(2015长春赛区网络赛1007)暴力
  9. TKinter之文本域与多窗口
  10. MySQL中SSL配置
  11. Oracle数据库 External component has thrown an exception
  12. MS-queue算法相关
  13. Oracle的完整练习,纯手工打字,可能有一两点错误。。。
  14. 读书笔记:《HTML5开发手册》Web表单
  15. linux 驱动入门6
  16. java数据库编程之DAO模式
  17. 十、Python练习----基础搭建飞机大战
  18. Asp.Net Core 轻松学-多线程之Task(补充)
  19. msfconlose基本命令
  20. Linux centos 7/ubantu下: 用 C 语言连接 MySQL数据库

热门文章

  1. 表单校验插件(bootstrap-validator)
  2. Serializable资料整理
  3. servlet-后台获取form表单传的参数
  4. 安装Oracle客户端时,检查系统要求时状态为错误的解决办法
  5. .Net并行计算支持嵌套事务的方法
  6. selenium菜单操作
  7. 图像局部显著性—点特征(SiftGPU)
  8. Typeclassopedia
  9. 【转】在VMware中为Linux系统安装VM-Tools的详解教程
  10. res对象json,redirect