Robberies


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12462    Accepted Submission(s): 4623

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before
retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.



His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line
j gives an integer Mj and a floating point number Pj . 

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.



Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05



Sample Output

2

4

6

题目大意:有一个强盗要去几个银行偷盗。他既想多投点钱,又想尽量不被抓到。已知各个银行

的金钱数和被抓的概率,以及强盗能容忍的最大被抓概率。求他最多能偷到多少钱?

思路:背包问题,原先想的是把概率当做背包,在这个范围内最多能抢多少钱。

可是问题出在概率这里,一是由于概率是浮点数。用作背包必须扩大10^n倍来用。二是最大不

被抓概率不是简单的累加。二是p = (1-p1)(1-p2)(1-p3) 当中p为最大不被抓概率,p1。p2。p3

为各个银行被抓概率。

第二次想到把银行的钱当做背包,把概率当做价值,总容量为全部银行的总钱数,求不超过被抓

概率的情况下,最大的背包容量是多少

dp[j] = max(dp[j],dp[j-Bag[i].v]*(1-Bag[i].p))(dp[j]表示在被抢概率j之下能抢的钱);

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std; struct bag
{
int v;
double p;
}Bag[10010];
double dp[10010]; int main()
{
int T,N;
double p;
scanf("%d",&T);
while(T--)
{
scanf("%lf %d",&p,&N);
int sum = 0;
for(int i = 0; i < N; i++)
{
scanf("%d%lf",&Bag[i].v,&Bag[i].p);
sum += Bag[i].v;
}
memset(dp,0,sizeof(dp));
dp[0] = 1;
for(int i = 0; i < N; i++)
{
for(int j = sum; j >= Bag[i].v; j--)
{
dp[j] = max(dp[j],dp[j-Bag[i].v]*(1-Bag[i].p));
}
} for(int i = sum; i >= 0; i--)
{
if(dp[i] > 1-p)
{
printf("%d\n",i);
break;
}
}
}
return 0;
}

最新文章

  1. Live YUV420 和 OpenCV Mat 的互相转换
  2. 安装openssl 扩展的时候出现Cannot find config.m4. Make sure that you run &#39;/usr/local/php/bin/phpize&#39; in the top level source directory of the module的解决方法
  3. genymotion和eclipse连接问题,一直出错
  4. aspose.cell 设置excel里面的文字是超链接
  5. js解决快速回车重复订单提交(客户端方式)
  6. HDU 1573 X问题 (中国剩余定理)
  7. [改善Java代码]建议采用的顺序是 List&lt;T&gt;、List&lt;?&gt;、List&lt;Object&gt;
  8. js的双等号类型转换
  9. 【Unity3D】Unity3D开发《我的世界》之四、创建一个Block
  10. mysql常用基础操作语法(八)~~多表查询合并结果和内连接查询【命令行模式】
  11. 如何用java控制你的电脑?
  12. vue版 文字滚动
  13. Linux中 ./configure --prefix命令
  14. Cbv源码简单分析图
  15. Linux下学习摄像头使用
  16. poj 1164 深度优先搜索模板题
  17. &quot;Native table &#39;performance_schema&#39;.&#39;session_variables&#39; has the wrong structure&quot;) [SQL: &quot;SHOW VARIABLES LIKE &#39;sql_mode&#39;&quot;]
  18. 文件中用WriteLine追加内容的两种方法
  19. javascript实现一行文字随不同设备自适应改变字体大小至字数完全展示
  20. Spring-Data-Redis 下实现jedis连接断开后自动重连

热门文章

  1. PCB MS SQL 排序应用(row_number rank dense_rank NTILE PARTITION)
  2. python-day4 运算符,if判断, for循环
  3. DCOM 找不到 office word 的解决方法
  4. EditPlus 2:用空格替换制表符
  5. 数据库操作通用函数,增强可重复利用性能C#,asp.net.sql2005
  6. 使用GetInvocationList对委托链进行更多的控制
  7. RabbitMQ .NET消息队列使用入门(二)【多个队列间消息传输】
  8. Android Retrofit 2.0文件上传
  9. 【Oracle】详解10053事件
  10. MAVEN - 生命周期(1)