A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:

10 1.80 1.00

3 2 3 5

1 9

1 4

1 7

0 7

2 6 1

1 8

0 9

0 4

0 3

Sample Output:

42.4

分析

用邻接表法建图,用ret数组储存零售商的信息,用深度优先搜索法,从0开始搜索,知道遇到叶子节点(即是零售商),期间用level来储存层级,每一层表示原始价格乘以(1+r%).

#include<iostream>
#include<algorithm>
#include<vector>
#include<math.h>
using namespace std;
const int inf=9999999;
vector<int> G[100001];
int visited[100001]={0},ret[100001]={0},n,level=-1;
double p,r,sale=0;
void dfs(int root){
level++;
visited[root]=1;
if(G[root].size()==0){
sale+=p*pow(1+0.01*r,level)*ret[root];
level--;
return ;
}
for(int i=0;i<G[root].size();i++)
if(visited[G[root][i]]==0)
dfs(G[root][i]);
level--;
}
int main(){
cin>>n>>p>>r;
for(int i=0;i<n;i++){
int num,u;
cin>>num;
if(num!=0){
for(int j=0;j<num;j++){
cin>>u;
G[i].push_back(u);
}
}else{
cin>>u;
ret[i]=u;
}
}
dfs(0);
printf("%.1lf",sale);
return 0;
}

最新文章

  1. 细说websocket - php篇
  2. javascrpt事件
  3. 10款免费的响应式 WordPress 主题下载
  4. HTML5 UI框架Kendo UI Web中如何创建自定义组件(二)
  5. Orchard 精简版
  6. 继承(引用~析构~virtual)
  7. css 实现文字过长变成省略号(包含单行的and多行的)
  8. HTML5学习摘录
  9. win7远程连接ubuntu14.04.1桌面
  10. jmeter IP欺骗功能实现
  11. Docker镜像构建的两种方式
  12. 关于oracle视图小结
  13. maven项目引入sqljdbc4 找不到包的完美 解决方案。
  14. curl post请求总是返回417错误
  15. javascript基础之函数
  16. {windows故障}关于WIN7故障模块StackHash_0a9e解决方法
  17. 深入浅出PF 学习笔记---资源文件
  18. JwtUtils 工具类
  19. 算法笔记_222:串中取3个不重复字母(Java)
  20. Allegro16.6结构文件dxf文件的输出与导入——凡亿PCB

热门文章

  1. Android ListView 和 ScrollView 冲突问题
  2. setprecision、fixed、showpoint的用法总结(经典!!超经典!!)【转】
  3. C++模板(菜鸟教程)
  4. 【BZOJ 2565】 最长双回文串
  5. hash哈希
  6. MySQL:常用语句
  7. 通过Ajax和SpringBoot交互的示例
  8. c++之——————各种变量
  9. php 过滤敏感关键词
  10. A - Word