Sum of divisors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2063    Accepted Submission(s): 718

Problem Description
mmm is learning division, she's so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day!

But her teacher said "What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?" mmm get stuck and she's asking for your help.

Attention, because mmm has misunderstood teacher's words, you have to solve a problem that is a little bit different.

Here's the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.

 
Input
Multiple test cases, each test cases is one line with two integers.

n and m.(n, m would be given in 10-based)

1≤n≤10
9

2≤m≤16

There are less then 10 test cases.

 
Output
Output the answer base m.
 
Sample Input
10 2
30 5
 
Sample Output
110
112

Hint

Use A, B, C...... for 10, 11, 12......
Test case 1: divisors are 1, 2, 5, 10 which means 1, 10, 101, 1010 under base 2, the square sum of digits is
1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2) + .... = 6 = 110 under base 2.

 
Source
 
现在看觉得挺简单的,第一眼看时觉得挺难就没做,谁知道人家一下就AC了,直接一般的方法做加一点优化就行了
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
int vet[10000];
int main()
{
int n,m,all,sum,s,ii,i,t;
char str[17]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E'};
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==1)
{
printf("1\n");
continue;
}
all=n;sum=0;
for(i=2;i<all;i++)
{
if(n%i==0)
{
all=n/i;//注意这一步优化,最关键的一步,如果i是n的因数,那么我们直接把i和n/i一起算了,i的上界变成了n/i-1
// printf("%d %d",i,n/i);
s=0;
ii=i;
while(ii)
{
t=ii%m;
s+=t*t;
ii=ii/m;
}
ii=n/i;
while(ii)
{
t=ii%m;
s+=t*t;
ii=ii/m;
}
sum+=s;
}
}
s=0;
ii=n;
while(ii)
{
t=ii%m;
s+=t*t;
ii=ii/m;
}
sum+=s;
sum++;
t=0;
while(sum)
{
vet[t++]=sum%m;
sum=sum/m;
}
for(i=t-1;i>=0;i--)
{
printf("%c",str[vet[i]]);
} printf("\n"); }
return 0;
}

最新文章

  1. Hadoop2 自己动手编译Hadoop的eclipse插件
  2. Fedora 21 install chrome
  3. 剑指offer系列38----滑动窗口的最大值(不懂????????????????????????????????????????????????)
  4. C# 设置 窗口最大化
  5. ADO.NET之1-数据库连接---ShinePans
  6. C#中委托。
  7. 什么是Hash?Hash有哪些特性?
  8. Jquery里的特定小技巧
  9. [20180813]刷新共享池与父子游标.txt
  10. JavaScript的基本包装类型_String类型
  11. 用python设置定时任务
  12. 一、使用Navicat连接阿里云服务器宝塔面板里创建的数据库
  13. Filter(转载)
  14. kdevelop 添加对 C++11的支持
  15. O(N)的时间寻找最大的K个数
  16. 中国剩余定理模板 51nod 1079
  17. mysql存储表情字符
  18. 【Spring学习笔记-MVC-11--】Spring MVC之表单标签
  19. 基于Vue的简单通用分页组件
  20. Python 模块化 import 语句介绍(一)

热门文章

  1. Java实战之02Hibernate-04多表映射
  2. WTL 中的常见问题汇总
  3. C++ DLL 获取 MSI Property
  4. Python3 IO
  5. 51nod1079中国剩余定理
  6. SQL注入原理二
  7. mvc框架下,怎样用cookie实现下次自动登录
  8. OFBiz之SVN下载地址
  9. 【Bean】 这才是bean,一直没仔细看
  10. repo manifest xml 文件修改后提交命令