Problem Description

The International Clown and Pierrot Competition (ICPC), is one of the most distinguished and also the most popular events on earth in the show business.

One of the unique features of this contest is the great number of judges that sometimes counts up to one hundred. The number of judges may differ from one contestant to another, because judges with any relationship whatsoever with a specific contestant are temporarily excluded for scoring his/her performance.

Basically, scores given to a contestant’s performance by the judges are averaged to decide his/her score. To avoid letting judges with eccentric viewpoints too much influence the score, the highest and the lowest scores are set aside in this calculation. If the same highest score is marked by two or more judges, only one of them is ignored. The same is with the lowest score. The average, which may contain fractions, are truncated down to obtain final score as an integer.

You are asked to write a program that computes the scores of performances, given the scores of all the judges, to speed up the event to be suited for a TV program.

Input

The input consists of a number of datasets, each corresponding to a contestant’s performance. There are no more than 20 datasets in the input.

A dataset begins with a line with an integer n, the number of judges participated in scoring the performance (3 ≤ n ≤ 100). Each of the n lines following it has an integral score s (0 ≤ s ≤ 1000) marked by a judge. No other characters except for digits to express these numbers are in the input. Judges’ names are kept secret.

The end of the input is indicated by a line with a single zero in it.

Output

For each dataset, a line containing a single decimal integer indicating the score for the corresponding performance should be output. No other characters should be on the output line.

Sample Input

3

1000

342

0

5

2

2

9

11

932

5

300

1000

0

200

400

8

353

242

402

274

283

132

402

523

0

Sample Output

342

7

300

326

分数都是整数!平均分也要是整数!

评委打分,去掉一个最高分,去掉一个最低分,求剩下的平均分!

不用四舍五入。直接舍去小数位就可以。

import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int n=sc.nextInt();
if(n<=0){
return ;
}
int sum =0;
int min = sc.nextInt();
int max=min;
sum=max;
int b;
for(int i=1;i<n;i++){
b = sc.nextInt();
if(b>max){
max=b;
}
if(b<min){
min=b;
}
sum+=b;
}
sum=sum-min-max;
System.out.println((int)(sum/(n-2)));
}
}
}

最新文章

  1. FORTRAN 90标准函数(一) (转)
  2. storm 配置,呵呵。
  3. yaf框架使用(centos6.5)
  4. php课程---Json格式规范需要注意的小细节
  5. Oracle 创建主键自增表
  6. Java算法-希尔排序
  7. maven Spring 4.2+SpringMVC+dubbo解决TypeProxyInvocationHandler.invoke(SerializableTypeWrapper.java:239)
  8. Bootstrap_排版_表格
  9. 在Excel中将数字设置成文本格式的技巧
  10. KVM管理平台openebula安装
  11. iOS wkwebview懒加载中遇到的问题
  12. ASP.NET后台调用API方法
  13. rethinking imageNet pre-training
  14. day 24 二十四、组合、继承、方法重写和重用、super()
  15. JDK动态代理(3)--------动态代理具体实现
  16. 安装Vue和创建一个Vue脚手架项目
  17. 【代码笔记】Web-JavaScript-JavaScript用法
  18. php 当前时间 当前时间戳和数据库里取出的时间datetime格式进行比较大小
  19. 关于express项目的创建与启动
  20. .net使用httpHandler添加图片防盗链

热门文章

  1. Unity3D GUI学习之GUILayout控件及使用
  2. sql server 2005 大数据量插入性能对比
  3. SSL VPN 详解
  4. 浅析CSS中的haslayout
  5. java_设计模式_策略模式_Strategy pattern(2016-07-15)
  6. 【转】jQuery教程
  7. 性能测试实践-linux
  8. Grunt:多个css,js,进行单独压缩
  9. DB2JAVIT:RC=9505解决方案
  10. js手机站跳转