Packets
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 48911   Accepted: 16570

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

Source

[Submit]   [Go Back]   [Status]   [Discuss]

 #include<cstdio>
#include<iostream>
using namespace std; int main()
{
int n, a, b, c, d, e, f, y, x; // n用来存放箱子数,y用来存放2*2的空位数,x用来存放1*1的空位数。
int u[] = {, , , }; // u表示3*3箱子数目为4的倍数,4的倍数+1,4的倍数+2,4的倍数+3时,为3*3产品打开新箱子中2*2的空位数。
while() {
cin >> a >> b >> c >> d >> e >> f;
if(a == && b == && c == && d == && e == && f == ) break;
n = f + e + d + (c + ) / ; // **计算技巧,(c + 3)/4等于c除以4向上取整。
y = * d + u[c % ];
if(b > y) n += (b - y + ) / ;
x = * n - * f - * e - * d - * c - * b;
if(a > x) n += (a - x + ) / ;
cout << n << endl;
}
return ;
}

最新文章

  1. 各种排序算法的分析及java实现
  2. LPTHW 笨方法学python 19章
  3. (转载)Autodesk面试技术题解答
  4. Memcached入门
  5. 将表中数据生成SQL语句
  6. sublime text修改TAB缩进为空格
  7. android的init过程分析
  8. 电脑报2014年第43期 pdf高清版
  9. WebForm MapPageRoute 路由配置
  10. 学习笔记——访问者模式Visitor
  11. download 下载文件 IE兼容性处理
  12. options.go
  13. Dapper批量操作实体
  14. SAP生产机该不该开放Debuger权限
  15. Verilog TestBench Coding Style
  16. [javascript]Three parts of javascript code snippet
  17. HDU.5985.Lucky Coins(概率DP)
  18. C++ 结构体和枚举
  19. JS中创建对象的方法及json
  20. centos配置虚拟主机virtualhost,让服务器支持多网站多域名(转)

热门文章

  1. Robotium--scroll操作系列
  2. linux开机自动启动脚本
  3. mysql删除数据库报错及解决方法
  4. mysql数据库安装方法
  5. 01-资料管理器(Directory/DirectoryInfo操作文件夹类)
  6. 使用HighCharts实现实时数据展示
  7. MySql中的时间类型datetime,timestamp,date,year比较
  8. &#39;Invalid update: invalid number of rows in section xx. The number of rows contained in an existing section after the update (xxx)...
  9. php 通过ip获取地理位置
  10. Jq/Js收集