Problem Description
 
It is the king's birthday before the military parade . The ministers prepared a rectangle cake of size n×m(1≤n,m≤10000) . The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut the rectangle cake into two pieces, one of which should be a square cake.. Since he loves squares , he will cut the biggest square cake. He will continue to do that until all the pieces are square. Now can you tell him how many pieces he can get when he finishes.
Input
The first line contains a number T(T≤), the number of the testcases.

For each testcase, the first line and the only line contains two positive numbers n,m(≤n,m≤).
Output
For each testcase, print a single number as the answer.
Sample Input

 
Sample Output

hint:

For the first testcase you can divide the into one cake of $\times2$ ,  cakes of $\times $
Source
 

模拟,过程类似求gcd,每次减去最小的边即可。

 #pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<math.h>
#include<algorithm>
#include<queue>
#include<set>
#include<bitset>
#include<map>
#include<vector>
#include<stdlib.h>
#include <stack>
using namespace std;
#define PI acos(-1.0)
#define max(a,b) (a) > (b) ? (a) : (b)
#define min(a,b) (a) < (b) ? (a) : (b)
#define ll long long
#define eps 1e-10
#define MOD 1000000007
#define N 1000000
#define inf 1e12
int n,m;
int main()
{
int t;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
int ans=;
while(n!=m){
ans++;
if(n>m) n-=m;
else m-=n;
}
printf("%d\n",ans+); }
return ;
}

最新文章

  1. Spring 3.0 AOP (一)AOP 术语
  2. 【Alpha】十天屠龙记
  3. OC基础--对成员变量的封装
  4. mobx源码解读4
  5. s3c2440 mpll
  6. JfreeChart的使用
  7. C语言typeof详解 offsetof
  8. sqlserver2008r2 127.0.0.1 用户sa登录失败 错误18456
  9. 转载:C++ STL set学习
  10. HDU 4571 Travel in time ★(2013 ACM/ICPC长沙邀请赛)
  11. myeclipse10.0优化
  12. 在opensips中记录通话记录
  13. Codeforce 57C Array
  14. 【BZOJ4530】大融合(Link-Cut Tree)
  15. Windows无法安装到这个磁盘
  16. jsonp原理,封装,应用(vue项目)
  17. 清除SqlServer日志
  18. 进程&amp;线程(转)
  19. 关于overflow-x: hidden隐藏滚动条失效的解决方案
  20. where 和 having区别

热门文章

  1. exec与xargs区别
  2. HTML与CSS入门——第十一章  在网页中使用图像
  3. 当chm文档点击左侧,右侧无内容时的解决方案
  4. web并发访问的问题
  5. 洛谷 P1896 互不侵犯King
  6. Cocos2d-x 3.x部署到安卓
  7. 初识CLR
  8. jQuery选择器的学习
  9. Asp.net mvc 3 file uploads using the fileapi
  10. php性能效率优化