Cow Multiplication
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12210   Accepted: 8509

Description

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A andB. For
example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.

Input

* Line 1: Two space-separated integers: A and B.

Output

* Line 1: A single line that is the A*B in Bessie's style of multiplication.

Sample Input

123 45

Sample Output

54

还是水题。。。字符串按位乘,再相加。

代码:

#include <iostream>
#include <cmath>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std; int main()
{
string m,n;
cin>>m>>n; int i,j,result=0;
for(i=0;i<m.length();i++)
{
for(j=0;j<n.length();j++)
{
result += (m[i]-'0')*(n[j]-'0');
}
}
cout<<result<<endl;
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. js 对象 copy 对象
  2. Docker中的镜像分层技术详解
  3. 构建基于WinRT的WP8.1 App 01:页面导航及页面缓存模式
  4. 取客户的银行帐号SQL
  5. 在ubuntu下真机调试android程序出现设备没有访问权限
  6. Java中的return
  7. C#制作在线升级程序
  8. LINUX 内核2
  9. IIS的Unicode漏洞攻击
  10. GiB与GB
  11. 奇怪的JS正则表达式问题
  12. 3.Java日志框架slf4j、jcl、jul、log4j1、log4j2、logback大总结
  13. android studio多渠道多包名多apk打包
  14. 去除ArrayList集合中的重复自定义对象元素
  15. IDA显示字节机器码
  16. 解决关于phpstorm打开速度很慢的问题
  17. Cocos Creator 获取节点的方式
  18. Git的各种状态
  19. bzoj3277
  20. 微信支付开发出现redirect_uri参数错误的解决方法

热门文章

  1. Oracle查看正在执行的存储过程
  2. bootloader 详细介绍
  3. php 实现店铺装修7
  4. 二十三 NoSql&amp;Redis及其安装
  5. 标准查询运算符---LINQ
  6. HihoCoder 1246:王胖浩与环
  7. NFC性价比高频读卡器首选方案:FM17550
  8. linux 常用文件命令记录
  9. thinkphp5+python.apscheduler实现计划任务
  10. maven详解 之 pom.xml