Orders
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9940   Accepted: 6048

Description

The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores
manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking. 



You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece
during the day. 

Input

Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn't exceed 200. 

Output

Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods. Each ordering of warehouses is
written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes. 

Sample Input

bbjd

Sample Output

bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb

大水,直接next_permutation。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std; char test[250]; int main()
{
while (cin >> test)
{
sort(test, test + strlen(test));
do {
cout << test << endl;
} while (next_permutation(test, test + strlen(test)));
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. C#数字日期装换为中文日期
  2. PHPer书单
  3. SourceTree - 正在检查源... When cloning a repository, &quot;Checking Source&quot; spins forever
  4. vimperator学习教程
  5. android-volley-at-a-glance
  6. HDU 1425 sort 【哈希入门】
  7. TFS 2012使用简介(一)
  8. oracle中的rowid和数据行的结构
  9. c/c++ double的数字 转成字符串后 可以有效的避免精度要求不高的数
  10. servlet操作数据库
  11. tomcat服务器设置用户名和密码
  12. 4. svg学习笔记-文档结构元素和样式的使用
  13. Python local error
  14. xhtml的3種文檔聲明類型
  15. navicat报caching_sha2_password异常
  16. expdp和impdp快速导出导入,不用创建虚拟目录
  17. Qt5模型/视图结构-视图(View)
  18. Bitter Sweet Symphony
  19. iOS开发短信验证码封装 方便好用
  20. 如何在windows下用IDA优雅调试ELF

热门文章

  1. burpsite 和jdk的配置
  2. es678910语法糖
  3. 019.CI4框架CodeIgniter辅助函数类之:Array数组查询
  4. 吴裕雄--天生自然java开发常用类库学习笔记:SortedMap类
  5. Day 30:HTML和CSS在Java项目中常用语法
  6. Golang的进制转换实战案例
  7. I0.0 上升边沿 清空 MW10~MW58 联系多个知识点融合
  8. 1 —— js 语法回顾 —— 数据类型。流程控制。数组
  9. 2018年Android面试题含答案--适合中高级(下)(转)
  10. Laravel框架的学习