You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

  • (a) if it is the empty string
  • (b) if A and B are correct, AB is correct,
  • (c) if A is correct, (A ) and [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input

The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line. Note that the string can contain arbitrary spaces and it can even be empty.

Output

A sequence of Yes or No on the output file.

Sample Input

3
([])
(([()])))
([()[]()])()

Sample Output

Yes
No
Yes

HINT

栈操作

Accepted

#include<bits/stdc++.h>
using namespace std; int main() {
ofstream fcout;
fcout.open("temp.txt");
int sum, flag = 0;
string s;
cin >> sum;getchar();
while (sum--) {
stack<char>S;
flag = 0;
getline(cin, s);
for (int i = 0;i < s.length();i++) {
if (s[i] == '['|| s[i] == '(')S.push(s[i]);
else if (s[i] == ')')
if (!S.empty() && S.top() == '(')S.pop();
else { flag = 1;break; }
else if (s[i] == ']')
if (!S.empty() && S.top() == '[')S.pop();
else { flag = 1;break; }
}
cout << (S.empty() && !flag ? "Yes" : "No") << endl;
}
}

最新文章

  1. Linux系统安装LAMP
  2. RFIDler - An open source Software Defined RFID Reader/Writer/Emulator
  3. .net 加水印 图片变大很多 解决方法
  4. 【动态规划】Vijos P1616 迎接仪式
  5. MVC Razor 一些常用的方法
  6. Opencv2.2版本以上CvvImage类的使用
  7. 【javascript】数组的操作
  8. struct和union的区别
  9. &lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt; 的作用
  10. js分析 有_道_翻_译 md5
  11. Python 输出格式符号
  12. thinkphp5 如何使用查询事件?
  13. GCC编译器原理(二)------编译原理一:目标文件
  14. 【C++】解析C++运行环境的搭建
  15. Vuejs——(10)组件——父子组件通信
  16. 用c语言实现http请求
  17. MUI 打包android app
  18. CDB和PDB的创建、连接、启动、关闭
  19. ios中LeveyPopListView 弹出view的用法
  20. AFO预定

热门文章

  1. 1090 Highest Price in Supply Chain——PAT甲级真题
  2. 扒几个 3D 模型备用
  3. JVM线上故障初步简易排查
  4. 20201228 买卖股票的最佳时机 IV(困难)
  5. 读懂框架设计的灵魂—Java反射机制
  6. 几种常见css布局
  7. 后端程序员之路 20、python复习
  8. 10. vue之webpack打包详解
  9. Google单元测试框架gtest之官方sample笔记3--值参数化测试
  10. javascript处理HTML的Encode(转码)和解码(Decode)