Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).

Sample Input

4 11

8.02

7.43

4.57

5.39

Sample Output

2.00

//给你n段电缆,然后给出一个k代表要求从n段截取的段数
//然后让你从这n段电缆中截取等长度的电缆,问最大能截取的长度是多大
#include<string>
#include<stdio.h>
#include<iomanip>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll; int n,k;
int a[10005]; int judge(int x)
{
int sum=0;
for(int i=0; i<n; i++)
sum+=a[i]/x;
if(sum>=k) return 1;
else return 0;
}
int main()
{
while(~scanf("%d%d",&n,&k))
{
for(int i=0; i<n; i++)
{
double f;
scanf("%lf",&f);
a[i]=(int)(f*100);
}
sort(a,a+n);
int high=a[n-1],low=1;
while(low<=high)
{
int mid=(low+high)>>1;
if(judge(mid)) low=mid+1;
else high=mid-1;
}
cout<<fixed<<setprecision(2)<<(double)high/100.0<<endl;//fixed 和 setpriecision 连用可以控制输出
}
return 0;
}

最新文章

  1. Linux学习笔记(3)-常用命令
  2. Codeforces Round #210 (Div. 2) A. Levko and Table
  3. iOS开发小技巧
  4. dlib库使用
  5. hibernate manytoone中的lazy EAGER
  6. OCI_ERROE - errcode[1591],errmsg[ORA-01591:
  7. WebApi(三)-属性路由 自定义访问路径
  8. oracle单行函数之类型转换
  9. leetcode刷题总结
  10. tp框架知识 之(链接数据库和操作数据)
  11. .NET 发布网站步骤
  12. Java单例模式的5种实现方式
  13. 开放源代码的设计层面框架Spring——day03
  14. Boosting Static Representation Robustness for Binary Clone Search against Code Obfuscation and Compiler Optimization(二)
  15. 2019.1.17 homework
  16. 严重: The web application [] registered the JDBC driver [com.microsoft.sqlserver.jdbc.SQLServerDriver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDB
  17. PHP开发安全问题
  18. winfrom 窗口起始位置为屏幕中央
  19. iOS 错误 undefined symbols for architecture i386
  20. mybatis select/insert/update/delete

热门文章

  1. 【BZOJ】4764: 弹飞大爷 LCT
  2. 【洛谷 P3648】 [APIO2014]序列分割 (斜率优化)
  3. 使用批处理方式从svn 检出DEMO
  4. Nginx实现404页面的几种方法【转】
  5. python爬虫多线程编程
  6. 字典对象的 Pythonic 用法(上篇)
  7. 2017百度春招&lt;有趣的排序&gt;
  8. C# winform或控制台Properties.Settings.Default的使用及存储位置
  9. 构建最基础的Spring项目及所需要的jar包
  10. python的scrapy框架