时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:3093

解决:1255

题目描述:

You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.

输入:

For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).

输出:

For each case, on the first line of the output file print the sequence in the reverse order.

样例输入:
5
-3 4 6 -8 9
样例输出:
9 -8 6 4 -3
来源:
2007年上海交通大学计算机研究生机试真题

思路:

数组倒序。注意用long long类型存储。

代码:

#include <stdio.h>

#define N 10000

int main(void)
{
int n, i;
long long a[N]; while (scanf("%d", &n) != EOF)
{
for(i=0; i<n; i++)
scanf("%lld", &a[i]); for(i=n-1; i>0; i--)
printf("%lld ", a[i]);
printf("%lld\n", a[i]);
} return 0;
}
/**************************************************************
Problem: 1039
User: liangrx06
Language: C
Result: Accepted
Time:0 ms
Memory:916 kb
****************************************************************/

最新文章

  1. MesaSQLite数据库的简单使用方法
  2. 点击页面任何位置隐藏div
  3. Git 常用几个操作
  4. Linux 下常用的压缩,解压方法
  5. 下载Xml文件方法
  6. JAVA生成EXCEL图表
  7. Mac OS X 10.10 Yosemite PHP 5.5.14 free type support fix
  8. 关于XPath的基本语法
  9. centos6.5 安装python3.5
  10. JSP注释及scriptlet &lt;%局部%&gt;&lt;%!全局%&gt;&lt;%=输出%&gt;
  11. intellij idea无效的发型版本1.8解决方案
  12. (网页)HTML小技巧的一些小技巧
  13. Javascript 将 HTML 页面生成 PDF 并下载
  14. 第十一章&#160;串 (c1)KMP算法:从记忆力到预知力
  15. How to Set Up an Rsync Daemon on Your Linux Server
  16. [翻译] LazyFadeInView 渐入显示text文本
  17. xlwings: Write Excel macro using python instead of VBA
  18. es6-promise.auto.js
  19. C++中sizeof(struct)怎么计算?(转)
  20. mDNS 原理的简单理解

热门文章

  1. [UR #3] 核聚变反应强度
  2. [LOJ6235]区间素数个数
  3. SQL Server Debugging with WinDbg – an Introduction
  4. 判断vps类型
  5. 给交换机端口设ip
  6. T4模板编辑器
  7. Hibernate之load和get的差别
  8. PHP提权之异步执行
  9. php hex2bin 物联网设备发送十六进制数据
  10. hibernate oneToMany 缓存