http://acm.hdu.edu.cn/showproblem.php?pid=1445

Problem Description
Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus - Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit - he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

 
Input
There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

Vi [TAB] Ti

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

 
Output
Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

 
Sample Input
4
20 0
25 -155
27 190
30 240
2
21 0
22 34
0
 
Sample Output
780
771

题解:贪心

代码:

#include <bits/stdc++.h>
using namespace std; #define inf 0x3f3f3f3f
int n; struct Node {
int v;
int t;
int need;
}node[10000]; int main(){
while(~scanf("%d", &n)){
if(!n) break; for(int i = 0; i < n; i ++)
scanf("%d%d", &node[i].v, &node[i].t); for(int i = 0; i < n; i ++){
if(node[i].t < 0) {
node[i].need = inf;
} else{
node[i].need = (int)((4500 * 3.6) / node[i].v + node[i].t);
if((int)(4500 * 3.6) % node[i].v)
node[i].need ++;
}
} int ans = node[0].need;
for(int i = 1; i < n; i ++)
ans = min(ans, node[i].need); printf("%d\n", ans);
}
return 0;
}

  

最新文章

  1. myWaterfall - jQuery瀑布流布局插件
  2. (一)Nand FLASH 原理讲解
  3. WebGL框架 -- three.js
  4. centos安装后iptables基本设置
  5. SQL Server错误与事务处理
  6. SQL Server面试题
  7. Zend Studio 错误集锦[PHP]
  8. Android Dialog用法
  9. Apache ab 测试工具使用(一)
  10. Thinkphp 空操作、空控制器、命名空间
  11. uva 10825 - Anagram and Multiplication(暴力)
  12. 再叙ASM
  13. Java的多态及注意事项
  14. 深蓝词库转换2.4版发布,支持最新的搜狗用户词库备份bin格式
  15. Java8自定义函数式编程接口和便捷的引用类的构造器及方法
  16. Codeforces 359E Neatness
  17. 实现类似于QQ空间相册的点击图片放大,再点后缩小回原来位置
  18. 学习笔记40—endnote点点滴滴
  19. Englis(二)
  20. importlib的用法

热门文章

  1. Spring boot中使用servlet filter
  2. SmallMQ发布
  3. JSONP 通用函数封装
  4. Angularjs基础(四)
  5. 解方程(hash,秦九韶算法)
  6. 【CodeForces 803 C】Maximal GCD(GCD+思维)
  7. CASE WHEN 小结
  8. python中的&quot;is&quot;与&quot;==&quot;比较
  9. Python序列删除重复数据
  10. C# WebClient 使用http免费代理