Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2398    Accepted Submission(s): 942

Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.

Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.

But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.

Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.

 
Input
The first line contains only one integer T, which is the number of test cases.

Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.

Hint

Range of test data:

T<= 100 ;

n<= 100000;

 
Output
For each test case, output one line contains the shorest possible complete text.
 
Sample Input
2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde
 
Sample Output
abcdabcd
qwertabcde

题意比较难理解,就是说给定两组字符串,第一组只有26个字符表对应明文中a,b,c,d....z可以转换第一个,第二个...第26个字符变成密文,

第二组字符串是给定的密文+明文,明文可能不完整(缺失或没有),叫你补完且整个密文+明文是最短的

如果有多种明文则取最大的明文

分析:因为可能有多种明文且密文>=明文,所以将字符串的前一半(一定是密文)转换成明文和后一部分进行匹配,如果从后面某个位置能匹配到末尾,则表示那一部分是明文,然后进行补充完整输出即可//这里根据key得到密文转换成明文的钥匙b,不用明文转换成密文匹配是因为明文可能有多种,后面一部分不一定是明文,根据b将密文转换成明文(一定是最大的明文,因为b里面转换成的明文字符一定是最大的,比如key:aa....,则b:b.....)

EKMP:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 999999999
using namespace std; const int MAX=100000+10;
char s1[MAX],s2[MAX],a[27],b[27];
int next[MAX]; void get_next(char *a,int len){
int k=0,i=1;
next[0]=len;//本题无作用
while(k+1<len && a[k] == a[k+1])++k;
next[1]=k;
k=1;
while(++i<len){
int maxr=k+next[k]-1;
next[i]=min(next[i-k],max(maxr-i+1,0));
while(i+next[i]<len && a[next[i]] == a[i+next[i]])++next[i];
if(i+next[i]>k+next[k])k=i;
}
} int main(){
int T,k;
cin>>T;
while(T--){
cin>>a>>s1;
for(int i=0;i<26;++i)b[a[i]-'a']=i+'a';
int len=strlen(s1);
for(int i=0;i<(len+1)/2;++i)s2[i]=b[s1[i]-'a'];//将密文转换为明文,密文长度>=明文长度
for(int i=(len+1)/2;i<=len;++i)s2[i]=s1[i];
get_next(s2,len);
for(k=(len+1)/2;k<len;++k){
if(next[k] == len-k)break;
}
cout<<s1;
for(int i=len-k;i<k;++i)cout<<b[s1[i]-'a'];
cout<<endl;
}
return 0;
}

KMP:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 999999999
using namespace std; const int MAX=100000+10;
char s1[MAX],s2[MAX],a[27],b[27];
int next[MAX]; void get_next(char *a,int len){
int i=-1,j=0;
next[0]=-1;
while(j<len){
if(i == -1 || a[i] == a[j])next[++j]=++i;
else i=next[i];
}
} int main(){
int T;
cin>>T;
while(T--){
cin>>a>>s1;
for(int i=0;i<26;++i)b[a[i]-'a']=i+'a';
int len=strlen(s1),k=len;
for(int i=0;i<(len+1)/2;++i)s2[i]=b[s1[i]-'a'];//将密文转换为明文,密文长度>=明文长度
for(int i=(len+1)/2;i<=len;++i)s2[i]=s1[i];
get_next(s2,len);
while(next[k]>len/2)k=next[k];
cout<<s1;
for(int i=next[k];i<len-next[k];++i)cout<<b[s1[i]-'a'];
cout<<endl;
}
return 0;
}

最新文章

  1. man page分類與說明
  2. args
  3. grep DEMO
  4. Linux登陆和欢迎信息修改
  5. Sublime Text 插件之常用20个插件
  6. Django Tutorial 学习笔记
  7. 彻底解决Android因加载多个大图引起的OutOfMemoryError,内存溢出的问题
  8. eclipse jsp html 格式化 format
  9. c语言的内存分析
  10. Java中的String类型
  11. bits change world
  12. 微服务之Spring cloud
  13. nginx实践(四)之静态资源web服务(防盗链)
  14. Badboy录制Jmter脚本
  15. win下查找端口占用进程并定位到具体程序
  16. idea环境配置
  17. Synchronized和lock的区别和用法
  18. eol-last的相关知识
  19. GIS入门基础知识点
  20. 【转】.Net 架构图

热门文章

  1. SQLite 字符串连接
  2. SMT贴片红胶基本知识
  3. 如何使用Excel和Word编辑和打印条形码
  4. WA(Write Amplification)写入放大
  5. pyqt中使用matplotlib绘制动态曲线 – pythonic
  6. Struts2 一张图片引发的bug
  7. Eclipse启动后一直Initializing Java Tooling (1%)
  8. localstroge可以在页面间传递数值;
  9. POJ3771+Prim
  10. ajax异步服务器获取时间