Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2

4 1 2 3 4

4 3 3 2 1

0

Sample Output

4

10

3

Author

lcy

题意:跳数字游戏,下一个数字必须比当前数字大,每一次都可以 获取当前数字的值

题解:dp求上升序列的和

Select Code

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm> using namespace std; const int maxn = 1050; int main()
{
int dp[maxn],s[maxn],n,i,j,Max,mm;
while(scanf("%d",&n)!=EOF&&n)
{
for(i=0;i<n;i++)
scanf("%d",&s[i]);
dp[0] = s[0];
Max = s[0];
for(i=1;i<n;i++)
{
mm = 0;
for(j=0;j<i;j++)
{
if(s[i]>s[j]&&mm<dp[j])
mm = dp[j];
}
dp[i] = mm + s[i];
Max = max(Max,dp[i]);
}
printf("%d\n",Max);
}
return 0;
}

最新文章

  1. 通过向页面写html代码导出excel
  2. (转)Linux的启动过程
  3. dblink连接的目标端 session不断的问题。
  4. OS10.11系统下 安装cocoapods 以及 安装cocoapods-xcode-plugin-master插件来加载三方框架
  5. MYSQL中关于日期处理的函数
  6. easyui tree 编辑后保留原先状态
  7. bzoj 1458 网络流
  8. 新浪微博客户端(5)-自定义UISearchBar
  9. Java面试葵花宝典
  10. java ServerSocket服务端编程
  11. 路径和 二叉树 leecode
  12. Jasper_crosstab_display a value of field in crosstab total row
  13. 全新E:网站不是之前排名浮动 相比于竞争对手究竟缺少了什么?
  14. nrm是什么?以及nrm的安装与命令
  15. 关于微信小程序的的总结
  16. Gradle 1.12用户指南翻译——第三十七章. OSGi 插件
  17. VS插件File Nesting
  18. Java中excel转换为jpg/png图片 采用aspose-cells-18.6.jar
  19. printf的执行顺序
  20. 使用log4cplus时遇到的链接错误:无法解析的外部符号 &quot;public: static class log4cplus::Logger __cdecl log4cplus::Logger::getInstance(class std::basic_string&lt;wchar_t,struct std::char_traits&lt;wchar_t&gt;,

热门文章

  1. iview中table的render()函数
  2. SpringBoot+Shiro+mybatis整合实战
  3. python使用cPickle模块序列化实例
  4. 论ul、ol和dl的区别
  5. 从Java到C++——union的使用方法
  6. Hystrix线程池配置
  7. Cron定时任务应用到Thinkphp – 贤生博客
  8. 【CS Round #44 (Div. 2 only) C】Check DFS
  9. 当spark遇见hbase
  10. toString方法和valueof()方法的区别