Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 461    Accepted Submission(s): 273

Problem Description
ZZX has a sequence of boxes numbered 1,2,...,n. Each box can contain at most one ball.

You are given the initial configuration of the balls. For 1≤i≤n, if the i-th box is empty then a[i]=0, otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.

 
Input
First line contains an integer t. Then t testcases follow. 
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.

 
Output
For each testcase, print "Yes" or "No" in a line.
 
Sample Input
5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4
 
Sample Output
No
No
Yes
No
Yes
 
Author
学军中学
 
Source
 
Recommend
wange2014   |   We have carefully selected several similar problems for you:       
 题意:两个数组,其中一个数组是当前的,另外一个是需要变换到的,你有m个按次序的操作,每次操作可以把[l,r]范围内的所有数任意排列,判断是否可以通过依次进行这些操作将当前数组变换到目标数组。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <algorithm>
#include <set>
using namespace std;
typedef long long ll;
typedef unsigned long long Ull;
#define MM(a,b) memset(a,b,sizeof(a));
const double eps = 1e-10;
const int inf =0x7f7f7f7f;
const double pi=acos(-1);
const int N=1005; struct node{
int x,y;
}a[N]; bool cmp(node a,node b)
{
return a.y<b.y;
} int b[N];
int main()
{
int cas,n,m;
scanf("%d",&cas);
while(cas--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++) {scanf("%d",&a[i].x);a[i].y=-1;}
for(int j=1;j<=n;j++)
{
scanf("%d",&b[j]);
for(int i=1;i<=n;i++)
if(a[i].x==b[j]&&a[i].y==-1)
{
a[i].y=j;
break;
}
}
while(m--)
{
int l,r;
scanf("%d%d",&l,&r);
sort(a+l,a+r+1,cmp);
}
bool flag=true;
for(int i=1;i<=n;i++)
if(a[i].y!=i) {flag=false;break;}
if(flag) printf("Yes\n");
else printf("No\n");
}
return 0;
}

  分析:比赛时感觉这道题跟以前做过的猪圈的那道最大流题目很像,,,后来发现还是不能那样做。

其实对于当前数组中的每种数值,找到目标数组中与之相同的数值,然后按着相对位置,给当前数组标上

目标数组中相对位置一样的数所在的实际位置就好了,,是一种贪心吧

最新文章

  1. sql 添加修改说明
  2. Google Map JavaScript API V3 实例大全
  3. 在Thinkphp3.2 中使用PHPMailer 发送邮件
  4. AngularJS中的控制器示例_3
  5. oracle数据库删除数据Delete语句和Truncate语句的对比
  6. inform表单验证,正则表达式,用户名,身份证,密码,验证码
  7. python 使用 &#39;python -m pip install --upgrade pip&#39;提示PermissionError: [WinError 5] 拒绝访问
  8. java线程数过高原因分析
  9. python“# -*- coding: UTF-8 -*-”
  10. FFmpeg 结构体学习(六): AVCodecContext 分析
  11. 利用OCR识别扫描的jpg、tif文件的文字
  12. 10、java5线程池之返回结果的任务之Callable与Future
  13. jenkins调用本地搭建sendmail邮件服务器发送邮件
  14. MQTT协议笔记之mqtt.io项目TCP协议支持
  15. ajax post data 获取不到数据,注意 content-type的设置 、post/get
  16. Django中CSS加载background url(&#39;&#39;)问题
  17. Keil for ARM与C++
  18. request方法传入动态参数的一个&quot;误区&quot;
  19. Socket通信简单实例(WCF调用Socket)
  20. 详解servlet的url-pattern匹配规则.RP

热门文章

  1. idea jar 中没有主清单属性
  2. vue技术分享之你可能不知道的7个秘密
  3. 【记忆化搜索】Navy maneuvers
  4. docker-配置网桥-自定义网络
  5. 27-Perl 进程管理
  6. layer插件loading快速应用示例
  7. 百度URL链接中文转码
  8. js之数据类型(对象类型——构造器对象——数组2)
  9. Editplus code
  10. Java学习笔记【十三、多线程编程】