题目

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants. Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found.

Sample Input:

6 8

7 2 3 4 6 5 1 8

5 3 7 2 6 4 8 1

2 6

8 1

7 9

12 -3

0 8

99 99

Sample Output:

LCA of 2 and 6 is 3.

8 is an ancestor of 1.

ERROR: 9 is not found.

ERROR: 12 and -3 are not found.

ERROR: 0 is not found.

ERROR: 99 and 99 are not found.

题目分析

已知二叉树中序和前序序列,求每个测试用例两个节点的最近公共祖先节点

解题思路

二叉树中序+前序唯一确定一棵二叉树,利用(前序第一个节点root在中序中将中序分为左子树和右子树)查找LCA

  1. u,v在root两边,则root为u,v最近公共祖先节点
  2. u,v都在root左边,则最近公共祖先在root左子树,递归查找
  3. u,v都在root右边,则最近公共祖先在root右子树,递归查找
  4. u==root,则u是v的最近公共祖先节点
  5. v==root,则v是u的最近公共祖先节点

Code

#include <iostream>
#include <map>
#include <vector>
using namespace std;
vector<int> pre,in;
map<int,int> pos;
void lca(int inL,int inR,int preL,int u,int v) {
if(inL>inR)return;
int rin=pos[pre[preL]], uin=pos[u], vin=pos[v];
if((uin<rin&&vin>rin)||(vin<rin&&uin>rin)) {
printf("LCA of %d and %d is %d.\n",u,v,in[rin]);
} else if(uin<rin&&vin<rin) { //u,v在左子树
lca(inL, rin-1, preL+1,u,v);
} else if(uin>rin&&vin>rin) { //u,v在右子树
lca(rin+1, inR, preL+(rin-inL)+1,u,v);
} else if(uin==rin) { //u是v lca
printf("%d is an ancestor of %d.\n",u,v);
} else if(vin==rin) { //v是u lca
printf("%d is an ancestor of %d.\n",v,u);
}
}
int main(int argc,char * argv[]) {
int m,n,u,v;
scanf("%d %d",&m,&n);
pre.resize(n+1);
in.resize(n+1);
for(int i=1; i<=n; i++) {
scanf("%d",&in[i]);
pos[in[i]]=i;
}
for(int i=1; i<=n; i++) {
scanf("%d",&pre[i]);
}
for(int i=0; i<m; i++) {
scanf("%d %d",&u,&v);
if(pos[u]==0&&pos[v]==0) { //都没找到
printf("ERROR: %d and %d are not found.\n",u,v);
} else if(pos[u]==0||pos[v]==0) {
printf("ERROR: %d is not found.\n",pos[u]==0?u:v);
} else {
lca(1,n,1,u,v);
}
}
return 0;
}

最新文章

  1. linux shell脚本查找重复行/查找非重复行/去除重复行/重复行统计
  2. linux动态时钟探索
  3. 网摘 窗体的旋转效果 wpf
  4. VC++ AfxBeginThread 与 CreateThread 的区别
  5. 0422 Step2-FCFS调度
  6. 深入剖析阿里巴巴云梯YARN集群
  7. swift 语法 - 以及学习资料
  8. jQuery操作元素
  9. 转:微信生成二维码java
  10. VMware安装Redhat6.5
  11. python 全栈开发笔记 4
  12. system libzip must be upgraded to version &gt;= 0.11
  13. bug Spring Mvc中Jsp页面获取不到Controller中的变量
  14. Java JDK版本切换--绝逼好使
  15. RedHat Linux下MQ安装步骤及MQ常用命令
  16. 打开IPHONE的sms.db短信文件 方法
  17. 【代码审计】iCMS_v7.0.7 admincp.app.php页面存在SQL注入漏洞分析
  18. MS datatype define(微软数据类型定义)
  19. Terminal shortcuts
  20. 集群中的session共享存储 实现会话保持

热门文章

  1. 百度地图javascript API,每个功能每天免费的次数
  2. 磁盘空间引起ES集群shard unassigned的处理过程
  3. SpringIOC初始化过程源码跟踪及学习
  4. AndroidStudio3.0打开Android Device Monitor
  5. MongoDB_01
  6. 定义一个共享数据块DB1 在DB1中定义一个数组 用程序 访问数据里面的某一个成员或者地址连续的成员
  7. 微服务框架中springboot启动的一个问题
  8. 165-PHP 文本替换函数str_replace(六)
  9. oracle学习笔记(4)
  10. 腾讯云服务器上搭建 2.176.3-1.1 版本的Jenkins,jdk 11