题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3746

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing
christmas presents to send to their girlfriends. It is believed that chain
bracelet is a good choice. However, Things are not always so simple, as is known
to everyone, girl's fond of the colorful decoration to make bracelet appears
vivid and lively, meanwhile they want to display their mature side as college
students. after CC understands the girls demands, he intends to sell the chain
bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls
to show girls' lively, and the most important thing is that it must be connected
by a cyclic chain which means the color of pearls are cyclic connected from the
left to right. And the cyclic count must be more than one. If you connect the
leftmost pearl and the rightmost pearl of such chain, you can make a
CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and
its cyclic count is 2:

Now CC has brought in
some ordinary bracelet chains, he wants to buy minimum number of pearls to make
CharmBracelets so that he can save more money. but when remaking the bracelet,
he can only add color pearls to the left end and right end of the chain, that is
to say, adding to the middle is forbidden.
CC is satisfied with his ideas and
ask you for help.

 
Input
The first line of the input is a single integer T ( 0
< T <= 100 ) which means the number of test cases.
Each test case
contains only one line describe the original ordinary chain to be remade. Each
character in the string stands for one pearl and there are 26 kinds of pearls
being described by 'a' ~'z' characters. The length of the string Len: ( 3 <=
Len <= 100000 ).
 
Output
For each case, you are required to output the minimum
count of pearls added to make a CharmBracelet.
 
Sample Input
3
aaa
abca
abcde
 
Sample Output
0
2
5
 
题目大意:
在字符串的左边或者右边添加最少的字符,使得字符串拥有循环节;
 
 
解题思路:
根据直觉,不难发现好像和Next[len]有一定关系,一开始我看了样例,单纯的以为答案就是len-2*Next[len],十分天真
后来才发现,len-Next[len]就是最小循环节:
  
求出循环节之后,再做一点简单的数学计算就可以得到答案了。
(有一点是,如果循环节的组成是C[1…k]+C[1…m],那是不是就要在左边加字符,或者要做一些特殊处理呢?显然不是,至于为什么,例如abcdabcdab和badcbadcba)
 
AC代码:
 #include<cstdio>
#include<cstring>
#define MAX 100000+5
using namespace std;
int Next[MAX];
char pat[MAX];
int len,cycle;
void getnext()
{
int i=, j=-;
len=strlen(pat);
Next[]=-;
while(i<len)
{
if(j == - || pat[i] == pat[j]) Next[++i]=++j;
else j=Next[j];
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%s",pat);
getnext();
cycle=len-Next[len];
if(len%cycle==)
{
if(len/cycle==) printf("%d\n",cycle);
else printf("0\n");
}
else printf("%d\n",cycle-(len-len/cycle*cycle));
}
}

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1358

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 
Sample Input
3
aaa
12
aabaabaabaab
0
 
Sample Output
Test case #1
2 2
3 3
 
 
Test case #2
2 2
6 2
9 3
12 4
 

题目大意:

给出一个长度为N的字符串,对其每个前缀串(满足长度≥2,且可以为字符串本身),考察是否存在循环节循环(即存在循环节,且循环节个数≥2);

若存在,则输出该前缀串的长度,并且输出这个前缀串中循环节循环次数;

例如字符串:“aaa”:

  前缀串①:“aa”,长度为2,循环节个数为2;

  前缀串②:“aaa”,长度为3,循环节个数为3;

例如字符串:“aabaabaabaab”:

  前缀串①:“aa”,长度为2,循环节个数为2;

  前缀串②:“aabaab”,长度为6,循环节个数为2;

  前缀串③:“aabaabaab”,长度为9,循环节个数为3;

  前缀串④:“aabaabaabaab”,长度为12,循环节个数为4;

解题思路:

有了上面那题len-Next[len]的铺垫,本题就比较简单了,进行暴力枚举,判断之后输出即可。

AC代码:

 #include<cstdio>
#include<cstring>
#define MAX 1000000+5
int Next[MAX],len;
char pat[MAX];
void getNext()
{
int i=, j=-;
Next[]=-;
while(i<len)
{
if(j == - || pat[i] == pat[j]) Next[++i]=++j;
else j=Next[j];
}
}
int main()
{
int kase=;
while(scanf("%d",&len) && len!=)
{
scanf("%s",pat);
getNext();
printf("Test case #%d\n",++kase);
for(int i=,cycle;i<=len;i++)
{
cycle=i-Next[i];
if(i%cycle == && i/cycle >= ) printf("%d %d\n",i,i/cycle);
}
printf("\n");
}
}

最新文章

  1. 一步一步开发Game服务器(三)加载脚本和服务器热更新(二)完整版
  2. C++/java之间的Socket通信大小端注意事项
  3. loglikelihood ratio 相似度
  4. [SVN Mac自带SVN结合新浪SAE进行代码管理]
  5. 关于sql server 2008过期导致 MSSQLSERVER服务就无法启动,手动启动就报告错误代码17051。
  6. HTML 5 参考手册
  7. OC - 13.数据解析(JSON与XML)
  8. mysql5.5 无法创建实例,error 16001
  9. 怎样判断iOS App是通过哪种途径启动的?
  10. VS2013装扩展RazorGenerator
  11. Ajax/XHR/HTTP/jQuery Ajax
  12. 发送email
  13. 程序员50题(JS版本)(五)
  14. Docker 架构(二)【转】
  15. delphi 自动获取串口
  16. Codeforces Round #503 (by SIS, Div. 2) Solution
  17. 【Python深入】Python中继承object和不继承object的区别
  18. jquery选择器扩展之样式选择器
  19. makedown 软件
  20. C++编译器符号表有哪些内容?

热门文章

  1. Eclipse------maven使用Maven build编译web项目显示&quot; javax.servlet.http 不存在&quot;
  2. MongoDB的数据模型
  3. D盾 v2.0.6.42 测试记录
  4. HttpClient(五)-- 模拟表单上传文件
  5. 使用 urllib 处理 HTTP 异常
  6. [NodeJS] Node.js 编码转换
  7. 深入浅出MFC——消息映射与命令传递(六)
  8. &lt;转&gt;Python OOP(1):从基础开始
  9. 【面试题】新东方.NET工程师面试题总结
  10. Android设计和开发系列第一篇:Notifications通知(Develop—Training)