题目链接

Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

Output

For each colletcion, output Collection #k:'', where k is the number of the test case, and then eitherCan be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0

1 0 0 0 1 1

0 0 0 0 0 0

Sample Output

Collection #1:

Can't be divided.

Collection #2:

Can be divided.

分析:

Marsha和Bill收集了很多的石子,他们想把它均匀的分成两堆,但不幸的是,有的石子大且美观。于是,他们就给这些石子从1到6编号,表示石子的价值,以便他们可以获得相等的价值,但是他们也意识到这很 难,因为石子是不能切割的,石子的总价值也未必是偶数,例如,他们分别有一个价值为1和3的石子,2个价值为4的石子,这种情况下,就不能均分了。

此题属于多重背包的问题,就是将01背包和完全背包结合起来。

代码:

#include<iostream>
#include<stdio.h>
#include<cstdlib>
#include<string.h>
using namespace std;
int b[200005],dp[200005] ;
int main()
{
int a[7],t=1;
while(~scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]))
{ int i,j,sum=0;
for(i=1; i<=6; i++)
sum+=i*a[i];
if(sum==0)//输入结束的标志
return 0;
else
{
printf("Collection #%d:\n",t);
if(sum%2!=0)//sum如果为奇数u,则表示一定不能够平分
printf("Can't be divided.\n\n");
else
{
memset(dp,0,sizeof(dp));
for(i=1; i<=6; i++)
{
if(i*a[i]<sum/2&&a[i]!=0)//如果当前价值的背包不能够满足完全装满一个平均值,则转化为01背包求解
{
memset(b,0,sizeof(b));
int w=a[i],t1,t2;
t2=1;
for(j=1; j<w; j=j*2)//转化为二进制,大大节约啦时间
{
b[t2]=j;
w=w-j;
t2++;
}
t1=t2;
b[t1]=w;
for(t2=1; t2<=t1; t2++)
for(j=sum/2; j>=b[t2]*i; j--)
dp[j]=max(dp[j],dp[j-(b[t2]*i)]+i*b[t2]);
}
else if(i*a[i]>=sum/2)//如果当前背包的总价值能够满足一个人的平分背包,则转化为完全背包
{
for(j=i; j<=sum/2; j++)
dp[j]=max(dp[j],dp[j-i]+i);
}
}
if(dp[sum/2]==sum/2)
printf("Can be divided.\n\n");
else
printf("Can't be divided.\n\n");
}
}
t++;
}
return 0;
}

最新文章

  1. Scalaz(13)- Monad:Writer - some kind of logger
  2. SQL SERVER常用定义查询
  3. 面试题之【打印1到最大的N位数】
  4. SSH Key连接github提示Permission denied (publickey).错误
  5. EXT 省市三级联动及默认选择
  6. 优于CoreData的Realm数据库基础教程
  7. Tarjan 离线算法LCA
  8. C++ 编程输入输出语句
  9. python--multiprocessing多进程总结
  10. GET POST方法长度限制
  11. vim配置(vimplus)
  12. win7下硬盘安装win7+linuxUbuntu双系统方法
  13. 【JavaEE基础】在Java中如何使用jdbc连接Sql2008数据库
  14. swift 笔记 (二十) —— 泛型
  15. TI公司与MSP430单片机
  16. Oracle Instance
  17. SOFA 源码分析 — 负载均衡和一致性 Hash
  18. Visual Studio 2015开发Qt项目实战经验分享(附项目示例源码)
  19. 分布式任务调度系统xxl-job搭建(基于docker)
  20. HTML给table添加单线边框

热门文章

  1. oracle 不能是用变量来作为列名和表名 ,但使用动态sql可以;
  2. 【Nginx】均衡负载权重模式实现session数据同步
  3. delphi self 的使用
  4. UVA11625_Lines of Containers
  5. ZOJ1827_The Game of 31
  6. hdu3507 Print Article(斜率优化入门)(pascal)
  7. C++解析(11):对象的构造
  8. static变量的特点 - 只会有一份成员对象
  9. Eve-NG-Toolkit
  10. 【Visual Installer】如何注册自已的文件类型