问题描述:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

解题思路:

bfs,三个方向搜索,x=x+1,x=x-1,x=x*2,最先搜索到的就是用时最短的。

代码:

#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
using namespace std;
int n,k;
int a[]; struct node
{
int x;
int step;
}now,net; int bfs(int x)
{
queue<node> q;
now.x=x;
now.step=;
q.push(now);
while(q.size())
{
now=q.front();
q.pop();
//三种情况
if(now.x==k)return now.step;
net.x=now.x+;
if(net.x>=&&net.x<=&&a[net.x]==)
{
a[net.x]=;
net.step=now.step+;
q.push(net);
}
net.x=now.x-;
if(net.x>=&&net.x<=&&a[net.x]==)
{
a[net.x]=;
net.step=now.step+;
q.push(net);
}
net.x=now.x*;
if(net.x>=&&net.x<=&&a[net.x]==)
{
a[net.x]=;
net.step=now.step+;
q.push(net);
}
}
return -;
} int main()
{
while(~scanf("%d%d",&n,&k))
{
memset(a,,sizeof(a));
a[n]=;
int ans=bfs(n);
printf("%d\n",ans);
}
return ;
}

最新文章

  1. MySQL备份还原&mdash;&mdash;AutoMySQLBackup介绍
  2. [转]hibernateTools工具安装及使用总结(eclipse 3.6)
  3. ng2-timesheet, 一个timesheet.js的angular2复制版
  4. C++ inline(内联什么时候使用)
  5. 怎么在ubuntu上使用pidgin登陆QQ
  6. makefile工程管理
  7. 独立游戏大电影 原名(Indie.Game)
  8. JavaEE GenericServlet 解析
  9. 剑指Offer——知识点储备-故障检测、性能调优与Java类加载机制
  10. JDK8下Object类源码理解
  11. February 22nd, 2018 Week 8th Thursday
  12. socket 发送图片
  13. 【洛谷p2837】晚餐队列安排
  14. python学习过程中的踩坑记录&lt;若干,随时更新&gt;
  15. 【leetcode】solution in java——Easy2
  16. inline-blcok 之间的空白间隙
  17. Spirng boot 启动的时候进行监控检查不通过停止服务与自定义健康监控节点
  18. 【洛谷P2676】超级书架
  19. win10已计划自动重启怎么关
  20. Educational Codeforces Round 22 E. Army Creation 主席树 或 分块

热门文章

  1. Kali Linux常用服务配置教程启动DHCP服务
  2. 同时使用antd和css module
  3. 重新学习Java的开始~
  4. Windows下利用MKL加速caffe,与openblas比较
  5. Object类的方法
  6. 201771010126.王燕《面向对象程序设计(Java)》第六周学习总结
  7. Centos 7 上使用nginx为Node.js配置反向代理时错误:(13: Permission denied) while connecting to upstream
  8. What&#39;s the meaning of unqualified-id?
  9. webrtc如何进行错误恢复
  10. 从github上下载一个项目的子目录