Description

 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle,
facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official
starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available
person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three
numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

 4  8,  9  5,  3  1,  2  6,  10,  7

where  represents a space.

/////uva好坑啊,就没输出换行就WA。
#include<iostream>
#include<iomanip>
#include<string.h>
using namespace std;
int main()
{
int n[10000],a,b,c,i,j,k;
int s,l,b1,c1;
while(cin>>a>>b>>c&&a)
{
n[0]=-9999;
l=0;b1=0,c1=0;i=1;j=a;
memset(n,0,sizeof(n));
n[0]=n[0];
s=a;
while(s)
{l--;c1=b1=0;
for(;i<=a;i++)
{
if(n[i]==0)
b1++;
if(b1==b)
{cout<<setw(3)<<i;n[i]=l;s--;break;}
if(i==a)
i=0;
}
if(s>=0)
{
for(;j>0;j--)
{
if(j==a+1)
j--;
if(n[j]==0||n[j]==l)
c1++;
if(c1==c&&n[j]!=l)
{cout<<setw(3)<<j;n[j]=l;s--;} if(j==1)
j=a+1;
if(c1==c)
{if(s!=0)
cout<<',';
if(s==0)
cout<<endl;
break;}
}
} }
}
return 0;
}

版权声明:本文博客原创文章,博客,未经同意,不得转载。

最新文章

  1. 如何自定义FloatingActionButton的大小
  2. BCB遍历所有窗体的组件
  3. mac 功能修改。。。。
  4. ACM1720_A+Bcoming(进制转换的新思路)——代码超少哟!
  5. OC——NSString的常用方法
  6. mysql优化(1) 观察服务器周期性变化
  7. C语言程序转换为Python语言
  8. 重新想象 Windows 8 Store Apps (33) - 关联启动: 使用外部程序打开一个文件或uri, 关联指定的文件类型或协议
  9. JDBC(下)
  10. linux下磁盘占用达到100%了,找不到哪些大文件耗尽了磁盘
  11. 2018-2019-2 20165232《网络对抗技术》Exp1 缓冲区溢出实验
  12. #017 python实验课第五周
  13. mysql自增id超大问题查询
  14. Nginx反向代理的简单实现
  15. linux下怎样查看哪些进程占用swap空间
  16. es6的let与es5的var定义变量的区别
  17. Swift5 语言参考(三) 类型
  18. web工程迁移---在一个jboss5或jboss6中运行多个实例
  19. 原生DOM操作
  20. ZH奶酪:【Python】random模块

热门文章

  1. c++中的 堆和栈
  2. c++,基类声明的指针变量和引用类型变量可以指向派 生类的对象
  3. BZOJ 3544: [ONTAK2010]Creative Accounting( BST )
  4. BZOJ 3282: Tree( LCT )
  5. js回调函数2
  6. [转] 解析LayoutSubviews
  7. Linux下通过rm -f删除大量文件时提示&quot;-bash: /bin/rm: Argument list too long&quot;的解决方法
  8. 详解python2 和 python3的区别
  9. Java, C#, Swift语法对比速查表
  10. ios中的任务分段