Digital Roots

Time Limit: 1000ms   Memory limit: 65536K

题目描述

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
 
For example, consider the positive integer 24. Adding the 2 and the 4
yields a value of 6. Since 6 is a single digit, 6 is the digital root of
24. Now consider the positive integer 39. Adding the 3 and the 9 yields
12. Since 12 is not a single digit, the process must be repeated.
Adding the 1 and the 2 yeilds 3, a single digit and also the digital
root of 39.

输入

The input file will contain a list of
positive integers, one per line. The end of the input will be indicated
by an integer value of zero.

输出

For each integer in the input, output its digital root on a separate line of the output.

示例输入

24
39
0

示例输出

6
3

提示

请注意,输入数据长度不超过20位数字。
      题目要求:给你一串数字,这些数字的“和”,如果大于一位数,则再将他们的和数字的每一位再相加,如此下去,直到数字和为一位数字!
     算法思想很简单,多用了几个while循环,关键是思路要清晰!
 
#include <stdio.h>
#include <string.h> int main()
{
char s[50];
int a[50], e;
int i, j, k;
int sum;
while(scanf("%s", s)!=EOF )
{
if(s[0]=='0')
break;
int len=strlen(s);
e=0;
sum=0;
for(i=0; i<len; i++)
{
a[e++]=s[i]-48 ;
sum+=a[e-1];
}
if(sum<10)
printf("%d\n", sum );
else
{
int cnt=sum;
sum=0;
while(cnt>10)
{
while(cnt!=0)
{
sum=sum + (cnt%10);
cnt=cnt/10;
}
if(sum<10)
{
printf("%d\n", sum );
break;
}
else
{
cnt=sum;
sum=0;
}
}
}
}
return 0;
}

最新文章

  1. [node.js 学习]1.start a simple server
  2. AngularJS实现单页应用的原理——路由(Route)
  3. codeforces195c
  4. ocp 1Z0-047 1-60题解析
  5. 1A Theatre Square
  6. 在IE6/7/8下识别html5标签
  7. C# 利用反射查看类的信息
  8. 二.ubuntu14.04 3D特效设置
  9. 【deep learning学习笔记】注释yusugomori的LR代码 --- LogisticRegression.h
  10. JavaBean编辑器的简单介绍
  11. Android Notification 版本适配方案
  12. web开发中 代码解决部分IE兼容问题
  13. shell中空格的使用;空格替换;通配符
  14. OpenGL基础探究
  15. MDK5 and STM32Cube
  16. ASP.NET学习笔记(5)——原生Ajax基本操作
  17. WebService系列二:使用JDK和CXF框架开发WebService
  18. 2018/03/25 每日一个Linux命令 之 df
  19. eclipse工具maven项目打包文件不是最新修改的
  20. 学习HTTP

热门文章

  1. 运用Arc Hydro提取河网
  2. C#中使用泛型对照使用通用基础类型效率减少近一倍
  3. IIS 下 部署nodejs 使用反向代理
  4. python在windows系统中打印中文乱码
  5. cocos2dx 3.0rc怎样创建项目
  6. 设计模式之前之UML
  7. e.target与e.currentTarget对比
  8. hibernate 注解之 SequenceGenerator
  9. SecureCRT 设置字体跟颜色
  10. android 小游戏之数字猜猜