Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 81735    Accepted Submission(s): 18797

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the
end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6




解题心得:
1、这个题要求的是一个在序列中的一串连续的子序列,要求子序列的和最大,并且要求记录子序列的起始位置和终止位置。
2、可以将前面的数加在一起看作一个数,当前面的数为负数的时候则舍去,将当前这个数作为新的起点。用一个变量Max记录一下最大的值,当最大值被替换的时候记录一下终点和起点。理解了还是很容易的。



#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+100;
int num[maxn],dp[maxn];
int Start,End,now_start,Max;
int main()
{
int t;
int T;
scanf("%d",&t);
T = t;
while(t--)
{
memset(dp,0,sizeof(dp));
num[0] = -1;
now_start = 1;
Max = -1000000;
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&num[i]);
for(int i=1;i<=n;i++)
{
if(num[i] + dp[i-1] >= num[i])//前面的数不是负数
dp[i] = num[i] + dp[i-1];
else
{
dp[i] = num[i];//前面一个数是负数,将现在这个数作为新的起点
now_start = i;//当前起点,当出现最大值的用得到
}
if(dp[i] >= Max)//出现最大值,记录最大值,终点和起点
{
Start = now_start;
End = i;
Max = dp[i];
}
}
printf("Case %d:\n",T-t);
if(t != 0)
printf("%d %d %d\n\n",Max,Start,End);
else
printf("%d %d %d\n",Max,Start,End);
}
return 0;
}


最新文章

  1. HTML基本元素(四)
  2. 备份Mysql数据库BAT脚本
  3. 关于line-height
  4. 安装 Ubuntu 后的个人常用配置
  5. 设计模式之美:Structural Patterns(结构型模式)
  6. 像学历史课本一样学习Perl
  7. lintcode:带环链表
  8. HTML及简单标签介绍
  9. 怎么在后台修改前台html页面的key、title、description
  10. 在Eclipse中新建Maven项目
  11. windows下如何安装配置mysql-5.7-m14-winx64(zip格式的安装)
  12. js获取宽度设置thickbox百分比
  13. Create screenshots of a web page using Python and QtWebKit | Roland's Blog
  14. codeforces 6A. Triangle
  15. Java面试07|Redis数据库
  16. Java--反射的逐步理解
  17. 为Android Studio中的SettingsActivity定制任务栏
  18. Linq to Object原理
  19. Visual C++ 6.0中关于for的简单问题
  20. java类型的小知识List 等

热门文章

  1. easyui框架中关于dialog自带关闭事件的使用
  2. php 03
  3. web安全防御之RASP技术
  4. Eucalyptus简介
  5. C#基础知识图谱
  6. iOS核心动画高级技巧之核心动画(三)
  7. ssh登录卡住问题
  8. Linux最常用命令实战
  9. HDU3577 线段树(区间更新)
  10. SAP成都研究院马洪波:提升学习力,增强竞争力,收获一生乐趣