Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 20599   Accepted: 7673

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 



We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 



1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 

2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 



The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 



There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

题意:给出矩阵左上角和右下角坐标,矩阵里的元素 1变0 ,0 变1,然后给出询问,问某个点是多少。

题解:纠结了好久,看了这篇博客后秒懂http://blog.sina.com.cn/s/blog_626489680100k75p.html

先举个一维的样例:你要使区间[x,y]所有加上一个值v,结合树状数组的功能,能够类似扫气球那样,在x处加v, y+1处减1

这样假设你要求x处的值,就转换成求[1,x]的和了,比如 :一个n=6的数组,一開始为0  0  0   0  0  0

在[2,4]加上2后变成   0   2   0   0   -2    0  这样前缀和 sum[1]=0;sum[2]=2;sum[3]=2;sum[4]=2;sum[5]=0;sum[6]=0;

依次代表了每一个数的值。

二维的也一样,由于二维树状数组的getsum(int x,int y)函数是求矩阵(1,1)~(x,y)的值得和。也就类似于前缀和。原理和一维的一样

仅仅只是线操作改成了平面操作。自己能够画个图感受下。

即:

add(x,y,1);

                add(x,y1+1,-1);

                add(x1+1,y,-1);

                add(x1+1,y1+1,1);

然后查询单点就是求和了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#define N 1040
#define ll long long using namespace std; int n; int bit[N][N]; int sum(int i,int j) {
int s=0;
while(i>0) {
int jj=j;
while(jj>0) {
s+=bit[i][jj];
jj-=jj&-jj;
}
i-=i&-i;
}
return s;
} void add(int i,int j,int x) {
while(i<=n) {
int jj=j;
while(jj<=n) {
bit[i][jj]+=x;
jj+=jj&-jj;
}
i+=i&-i;
}
} int main() {
freopen("test.in","r",stdin);
int t;
cin>>t;
while(t--) {
int q;
scanf("%d%d ",&n,&q);
memset(bit,0,sizeof bit);
char c;
int x,y,x1,y1;
while(q--) {
scanf("%c",&c);
if(c=='C') {
scanf("%d%d%d%d",&x,&y,&x1,&y1);
add(x,y,1);
add(x,y1+1,-1);
add(x1+1,y,-1);
add(x1+1,y1+1,1);//重叠的部分加上
} else {
scanf("%d%d",&x,&y);
printf("%d\n",sum(x,y)%2);
}
getchar();
}
if(t)printf("\n");
}
return 0;
}

最新文章

  1. 启动Hive时出现的问题
  2. Mac OS Terminal 几个快捷键
  3. 字符匹配算法之Boyer-Moore算法
  4. jQuery判断当前元素是第几个元素
  5. (ios7) 解决Ios7中,Navigatebar 显示在主View中,和ios6 不一致问题
  6. hdu 2199 Can you solve this equation?(二分搜索)
  7. 让jar程序在linux上一直执行
  8. 一款点击图片进行无限循环的jquery手风琴特效
  9. MySQL中,把varchar类型转为date类型
  10. HDUOJ Clear All of Them I 状压DP
  11. C#中的转义字符
  12. Bootstrap入门(十三)组件7:导航条
  13. pdf如何转换为word文档
  14. c# 基于redis分布式锁
  15. Partition Numbers的计算
  16. 转:.NET 面试题汇总(二)
  17. PCB设计工程师面试题
  18. 你不知道的JavaScript学习笔记1——作用域
  19. 高德地图Demo运行报错 com.android.ide.common.process.ProcessException: Failed to execute aapt
  20. W3School学习网站

热门文章

  1. 【HDOJ5533】Dancing Stars on Me(计算几何)
  2. POJ 2168 Popular cows [Tarjan 缩点]
  3. asp.net几种开源上传控件,flash,ajax版,支持多文件
  4. MSClass (Class Of Marquee Scroll通用不间断滚动JS封装类) Ver 1.65
  5. 用email实现邮件模板
  6. 从零开始学习OpenCL开发(一)架构【转】
  7. shell script timer and 無限迴圈
  8. hdu3452 无向树去掉最小的边集使任何叶子与根不连通 / 最小割
  9. LeetCode OJ-- Longest Substring Without Repeating Characters ***@
  10. ASP.NET MVC验证所有属性是否合法