I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 79448    Accepted Submission(s):
30520

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。
不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M (
0<N<=200000,0<M<5000
),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符
C (只取'Q'或'U')
,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 
Output
对于每一次询问操作,在一行里面输出最高成绩。
 
Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output
5
6
5
9
 
Hint

Huge input,the C function scanf() will work better than cin

 
Author
linle
 
Source
 
Recommend
lcy
 
水题……
 
代码
#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std; inline int read(){
int x=0,f=1;char c=getchar();
for(;!isdigit(c);c=getchar()) if(c=='-') f=-1;
for(;isdigit(c);c=getchar()) x=x*10+c-'0';
return x*f;
}
const int MAXN=100001;
const int INF=999999;
int N,M;
int tr[800001];
int a[200001];
int A,B; void build(int l,int r,int rt){
if(l==r){
tr[rt]=a[l];
return ;
}
int mid=(l+r)>>1;
build(l,mid,rt*2);
build(mid+1,r,rt*2+1);
tr[rt]=max(tr[rt*2],tr[rt*2+1]);
return ;
}
void Upd(int l,int r,int rt,int k,int x){
if(l==r){
tr[rt]=x;
return ;
}
int mid=(l+r)>>1;
if(k<=mid) Upd(l,mid,rt*2,k,x);
else Upd(mid+1,r,rt*2+1,k,x);
tr[rt]=max(tr[rt*2],tr[rt*2+1]);
return ;
}
int Que(int l,int r,int rt,int L,int R){
if(l>=L&&r<=R){
return tr[rt];
}
int mid=(l+r)>>1,ans=0;
if(R>mid) ans=max(ans,Que(mid+1,r,rt*2+1,L,R));
if(L<=mid) ans=max(ans,Que(l,mid,rt*2,L,R));
return ans;
} int main(){
while(scanf("%d%d",&N,&M)!=EOF){
memset(tr,0,sizeof(tr));
for(int i=1;i<=N;i++) a[i]=read();
build(1,N,1);
while(M--){
char c;cin>>c;
A=read(),B=read();
if(c=='Q') printf("%d\n",Que(1,N,1,A,B));
else Upd(1,N,1,A,B);
}
}
}

最新文章

  1. ArcEngine 栅格数据
  2. MySQL中的while、repeat、loop循环
  3. win版本对比
  4. js去除中间空格
  5. Windows下msysGit使用及相关配置
  6. WebApi中直接返回json字符串的方法
  7. Android ListView用EditText实现搜索功能
  8. 【转载】CMake 简介和 CMake 模板
  9. windows程序移植linux
  10. ilog
  11. JavaScript里最有效率的功能特征检测方法
  12. Notepad++在编程使用时的小技巧
  13. BFC块级格式化上下文简述
  14. Selenium 初见
  15. hdu 验证角谷猜想 1279
  16. KOA中间件的基本运作原理
  17. 不使用synchronized和lock 锁实现线程安全单例
  18. vue 学习笔记—Es6
  19. 注解 java.lang.annotation.Inherited 介绍
  20. 设置vim支持gbk

热门文章

  1. 牛客网刷题(纯java题型 1~30题)
  2. HDU 2546 饭卡 (dp)
  3. 阿里云服务器部署笔记二(python3、Flask、uWSGI、Nginx)
  4. Nodejs mac版安装
  5. word 宏,脚本编程
  6. 统计Visual Studio项目的代码行数
  7. python基础===getattr()函数使用方法
  8. 数据库===轻量级mysql数据库管理工具
  9. 在Github里集成Readthedocs服务
  10. shell常见操作整理(更新)