A - Charm Bracelet

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Submit Status

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

题意:有N 个手镯, 允许最大重量为M, 每个手镯都有两个属性, W 和 D, 分别为重量和魅力值, 求在允许重量范围内所能达到的最大魅力值。

代码:

#include<stdio.h>
#include<string.h>
#define max(a, b)(a > b ? a : b)
#define N 21000

int main(void)
{
int dp[N];
int i, j, n, m;
int w[N], d[N];

while(scanf("%d%d", &n, &m) != EOF)
{
memset(dp, 0, sizeof(dp));
for(i = 1; i <= n; i++)
{
scanf("%d%d", &w[i], &d[i]);
}
for(i = 1; i <= n; i++)
{
for(j = m; j >= w[i]; j--)//j要倒推才能保证在推dp[j]时, max里dp[j]和dp[j-w[i]]保存的是状态dp[i-1][j] 和dp[i-1][j-w[i]]的值。
{

dp[j] = max(dp[j], dp[j-w[i]] + d[i]); //在容量为j时,i件物品所能达到的最大价值。
}
}

printf("%d\n", dp[m]);

}

return 0;
}


最新文章

  1. 1Z0-053 争议题目解析46
  2. 三道Javascript的练习题
  3. 【转】Thread.isBackground
  4. linux下对进程按照内存使用情况进行排序
  5. 【Unity】改变向量的方向而不改变其大小
  6. [转载] Can&#39;t create table &#39;./store/#sql-b2c_1a.frm&#39; (errno: 150)和sql execution error #1452添加外键时错误解决方法
  7. ubuntu apt-get install php
  8. window对象;document对象;
  9. C++三种内存分配方式
  10. SQL数据库开发知识总结:基础篇
  11. VS2015 C#.net4.6 windows的定时服务
  12. 【转】CxImage图像库的使用
  13. 【c#操作office】--OleDbDataAdapter 与OleDbDataReader方式读取excel,并转换为datatable
  14. Java基于Socket文件传输示例
  15. LeetCode 235. Lowest Common Ancestor of a Binary Search Tree (二叉搜索树最近的共同祖先)
  16. Dubbo(五) Dubbo入门demo——helloworld
  17. Win10_x86_x64PE维护光盘——我用过最好用的PE
  18. 1 Openwrt无线中继设置并访问外网
  19. 自动重置Language level 5 与 Java Complier 1.5
  20. 作用域中LHS查询和RHS查询

热门文章

  1. spring-cloud-gateway报错
  2. 深入学习MySQL 01 一条查询语句的执行过程
  3. linux DHCP 服务器
  4. Mabitis
  5. 19_07_8校内训练[sort]
  6. Bootstrap自带的那些常用插件
  7. 工具之awk
  8. IDEA debug下取消后续操作
  9. 从App.config中读取数据库连接字符串
  10. Redis搭建哨兵模式