Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1

10 20 30

2

6 8 10

5 5 5

7

1 1 1

2 2 2

3 3 3

4 4 4

5 5 5

6 6 6

7 7 7

5

31 41 59

26 53 58

97 93 23

84 62 64

33 83 27

0

Sample Output

Case 1: maximum height = 40

Case 2: maximum height = 21

Case 3: maximum height = 28

Case 4: maximum height = 342

Source

University of Ulm Local Contest 1996

Recommend

JGShining

题意:给n种立方体的长宽高,每种立方体都有无限个,立方体叠的时候需要留出站立的空间,即上面的立方体长和宽要小于下方的,求可以用这些立方体叠多高。

题解:每种立方体可以摆三种不同的状态,存储三种状态后就是一个求上升子序列的变形了。注意输出格式。

#include <algorithm>
#include <iostream>
#include <cstdio> using namespace std; struct node
{
int a,b,h;
}x[105]; bool cmp(node a,node b)
{
if(a.a==b.a)
return a.b<b.b;
return a.a<b.a;
} int main()
{
int n,a,b,c,i,k = 1,num,j,max_h,dp[105],max2;
while(scanf("%d",&n)!=EOF&&n!=0)
{
num = 0;
for(i=0;i<n;i++)
{
scanf("%d%d%d",&a,&b,&c);
x[num].h = c;
x[num].a = max(a,b);
x[num++].b = min(a,b);
x[num].h = b;
x[num].a = max(a,c);
x[num++].b = min(a,c);
x[num].h = a;
x[num].a = max(c,b);
x[num++].b = min(c,b);
}
sort(x,x+num,cmp);
max_h = 0;
for(i=0;i<num;i++)
{
max2 = 0;
for(j=0;j<i;j++)
{
if(x[j].a<x[i].a&&x[j].b<x[i].b&&dp[j]>max2)
max2 = dp[j];
}
dp[i] = max2 + x[i].h;
max_h = max(max_h,dp[i]);
}
printf("Case %d: maximum height = %d\n",k++,max_h);
}
return 0;
}

最新文章

  1. Visula Studio 2013/2015自定义快捷键
  2. C#的面向对象特性之封装
  3. 解决EasyUI-Datagrid和LinqToEntity结合应用时排序问题
  4. android实现 服务器功能
  5. python 安装第三方模块
  6. 开发XMPP IM
  7. Mysql 的一些异常解决
  8. 【设计模式 - 22】之策略模式(Strategy)
  9. Caused by: com.mysql.jdbc.MysqlDataTruncation: Data truncation: Truncated incorrect DOUBLE value: &amp;#39;L
  10. java发送邮件时遇到的坑
  11. ArrayList中的modCount与ConcurrentModificationException
  12. eCharts使用图表简单示例
  13. verilog语法实例学习(12)
  14. java.lang.IllegalStateException: Fragment bb{42261900} not attached to Activity
  15. 点斜杠 &amp; 如何查看linux程序安装位置 dpkg -L yyy
  16. spring管理hibernate,mybatis,一级缓存失效原因
  17. Testlink在CentOS、windows安装
  18. [CISCO] Telete/SSH 之 Port 绑定/端口安全
  19. 理解 atime,ctime,mtime (下)
  20. Java - 接口还是抽象类

热门文章

  1. ssh 连接vps
  2. 20190817-T1-LOJ6322「雅礼国庆 2017 Day6」Star Way To Heaven
  3. ckfinder提示从服务器读取XML数据出错
  4. win7关闭休眠功能,清除Hiberfil.sys
  5. day37 10-SH整合的案例练习
  6. SQL Sever实验三 视图与数据更新
  7. R语言可视化--颜色
  8. 怎么让一个不定宽高的div垂直水平居中?
  9. Thinkphp js、css压缩类minify
  10. CSS(中)篇