Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13,
H1, H2, ..., H13,
C1, C2, ..., C13,
D1, D2, ..., D13,
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
思路
  • 题目的大意就是给定扑克牌的洗牌顺序和次数,手动模拟即可
代码
#include<bits/stdc++.h>
using namespace std;
vector<string> v;
void Init()
{
char s[5] = {'S', 'H', 'C', 'D', 'J'};
string tmp = "";
v.push_back(" ");
for(int i=0;i<4;i++)
{
for(int j=1;j<=13;j++)
{
tmp = s[i] + to_string(j);
v.push_back(tmp);
}
}
v.push_back("J1");
v.push_back("J2");
}
int main()
{
int n;
cin >> n;
Init(); vector<string> tmp(v);
int t;
int order[54];
for(int i=0;i<54;i++)
{
cin >> order[i];
} while(n--)
{
for(int i=0;i<54;i++)
{
tmp[order[i]] = v[i+1];
}
v.clear();
v.assign(tmp.begin(), tmp.end());
}
for(int i=1;i<v.size()-1;i++)
cout << v[i] << " ";
cout << v[v.size()-1];
return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805442671132672

最新文章

  1. 你知道QQ有多少人同时在线么
  2. DNS(二)之构建域名解析缓存
  3. 日常开发中常见的HTTP协议的状态码
  4. hadoop MapReduce 笔记
  5. 单链表操作B 分类: 链表 2015-06-07 12:42 15人阅读 评论(0) 收藏
  6. MVC中的奇葩错误,参数转对象
  7. uva 11817 - Tunnelling the Earth
  8. MySQL 5.7.14 安装
  9. Servlet添加
  10. jquery实现名单滚动
  11. ios系统判断某些适配 __IPHONE_OS_VERSION_MAX_ALLOWED
  12. cpp(第十七章)
  13. python之生成器和列表推导式
  14. SQL 中左连接与右链接的区别
  15. 为wordpress后台登陆添加算术验证码
  16. 用递归方法求n阶勒让德多项式的值
  17. 函数(一.return)
  18. 逍遥大佬分享mysql知识
  19. Asp.net MVC检测到有潜在危险的 Request.Form 值
  20. 【Spring Boot&amp;&amp; Spring Cloud系列】单点登录SSO之OAuth2官方开发文档翻译

热门文章

  1. pandas优化
  2. python创建文件夹方法
  3. 3dmax 欢迎页卡住
  4. AtCoder AGC007E Shik and Travel (二分、DP、启发式合并)
  5. HAOI2010软件安装
  6. Linux 服务器安装jdk,mysql,tomcat简要教程
  7. Nginx事件管理之事件处理流程
  8. mongodb 单节点集群配置 (开发环境)
  9. Android热修复技术原理详解
  10. Fragment全解析系列