Cable master
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 32191
Accepted: 6888

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants
using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants
as far from each other as possible. 

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not
known and the Cable Master is completely puzzled. 

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed
by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two
digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly
two digits after a decimal point. 

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

Northeastern Europe 2001

解法一:浮点数二分           直接在double上二分

错因:没有向下取整

解答:二分+高精度

<span style="color:#3333ff;">#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
double a[10005];
int main()
{
int n,k;
while(~scanf("%d %d",&n,&k))
{
for(int i=1;i<=n;i++)
scanf("%lf",&a[i]);
int t=100;double r=100000,l=0,mid;
while(t--)
{
int cnt=0;mid=(r+l)/2.0;
for(int i=1;i<=n;i++)
cnt+=int(a[i]/mid); //记得取整
if(cnt>=k)
l=mid; //尽量向大的取
else
r=mid;
}
</span><span style="color:#ff0000;">printf("%0.2f\n",(floor(r*100))/100); //注意利用floor函数向下取整,所以要预先*100!!!!!!!!!!向下取整是关键</span><span style="color:#3333ff;">
}
return 0;
}</span>

解法二:整数二分           先乘以100再运算,最后/100

错因:l需要初始化为1而不能是0,否则会re;!!!!!!!!!!!!

解答:二分

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int a[10005];
int main()
{
int n,k,maxn;double temp;
while(~scanf("%d %d",&n,&k))
{
maxn=0;
for(int i=1;i<=n;i++)
{
scanf("%lf",&temp);
a[i]=int(temp*100);
if(a[i]>maxn)
maxn=a[i];
}
int mid,r=maxn,l=1;//l初始化为0会re,,因为l==0时若r==1或0则mid==0,下面的除以mid就会re!!!!!!!!!
while(l<=r)
{
int cnt=0;mid=(r+l)/2;
for(int i=1;i<=n;i++)
cnt+=int(a[i]/mid);
if(cnt>=k)
l=mid+1;
else
r=mid-1;
}
printf("%0.2lf\n",r*0.01);//注意是*0.01,不能为/100,因为r是整型
}
return 0;
}

最新文章

  1. Linux的主机规划和磁盘分区
  2. &lt;&lt;&lt; Tomcat运行提示The server does not support version 3.0
  3. Excel For Java
  4. LeetCode-Sudoku Solver (递归解法)
  5. linux源代码阅读笔记 八进制
  6. wdcp-apache开启KeepAlive提高响应速度
  7. springmvc传递json数据到前台显示
  8. c语言基础学习09_关于复合类型的复习
  9. printf 函数原型
  10. CVE-2017-7494 Linux Samba named pipe file Open Vul Lead to DLL Execution
  11. Android开发 解决EditText与NestedScrollView 滚动冲突问题
  12. 分布式链路跟踪 Sleuth 与 Zipkin【Finchley 版】
  13. Linux - 查看命令所属的软件包
  14. code::Blocks生成的dll 在 java jni 调用遇到的问题
  15. Spark Streaming 002 统计单词的例子
  16. 牛客网-《剑指offer》-重建二叉树
  17. UVAlive6807 T&#250;nel de Rata (最小生成树)
  18. [USACO08DEC]Patting Heads
  19. Win10開始菜单打不开
  20. jquery中的each

热门文章

  1. 洛谷 P1268 树的重量 题解
  2. pycharm 更换源 Windows Linux平台
  3. JavaSE--异常机制
  4. the Percentage Layout of Android (安卓的百分比布局)
  5. 前端页面多级联动传输数据类型问题(数组or字符串)后端处理
  6. Tomcat 7 自动加载类及检测文件变动原理
  7. 04 Python之while循环/格式化输出/运算符/编码
  8. 小米Air 13.3 安装Arch Linux
  9. maven学习之路二(2)
  10. opengl学习-利用模板测试勾画物体轮廓中出现的一个问题