18002 Z-Scan

时间限制:1000MS  内存限制:65535K
提交次数:0 通过次数:0

题型: 编程题   语言: 不限定

Description

Z-Scan is a method to scan data in a square matrix(矩阵). Fig.1 shows Z-Scan. Here, the number stands for
the scan sequence number of the element.

Our question is very simple. Given the size (n * n) of the square matrix and the row and column of the matrix element,
could you tell me the scan sequence number of the element?

输入格式

The first line is an integer N, the number of cases, 1<=N<=10
N lines follow. Each line contains 3 integers(n r c), The "n" stands for a square matrix in size of n * n.
The "r" is the row of the element. The "c" is the column of the element. 1 <= r, c <= n <= 100

输出格式

For each case, output the scan sequence number of the element.

输入样例

3
5 1 2
5 4 5
99 99 99

输出样例

2
23
9801

来源

Mr. Chen

作者

admin

模拟题打表,模拟的时候用dfs模拟

注意到只有两种方向,

一种是x + 1, y - 1

一种是x - 1, y + 1

其他那些向下和向左,是作为边界来处理的。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#define IOS ios::sync_with_stdio(false)
using namespace std;
#define inf (0x3f3f3f3f)
typedef long long int LL; #include <iostream>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <queue>
#include <string>
int n, r, c;
const int maxn = 1e2 + ;
int a[maxn][maxn];
int tonext[][] = {{, -}, {-, }};
void dfs(int num, int x, int y, int now) {
a[x][y] = num;
if (x == n && y == n) return;
if (now == ) { //减y的
if (y == && x != n) {
dfs(num + , x + , y, !now);
} else if (x == n) {
dfs(num + , x, y + , !now);
} else {
dfs(num + , x + tonext[now][], y + tonext[now][], now);
}
} else { //减x的
if (x == && y != n) {
dfs(num + , x, y + , !now);
} else if (y == n) {
dfs(num + , x + , y, !now);
} else {
dfs(num + , x + tonext[now][], y + tonext[now][], now);
}
}
}
void work() {
scanf("%d%d%d", &n, &r, &c);
a[][] = ;
dfs(, , , );
// for (int i = 1; i <= n; ++i) {
// for (int j = 1; j <= n; ++j) {
// printf("%d ", a[i][j]);
// }
// printf("\n");
// }
printf("%d\n", a[r][c]);
} int main() {
#ifdef local
freopen("data.txt","r",stdin);
#endif
int t;
scanf("%d", &t);
while (t--) work();
return ;
}

最新文章

  1. 分析js中的constructor 和prototype
  2. MySql的一些用法
  3. Java设计模式之建造者模式(Builder)
  4. const 和 readonly
  5. 17.如何修改SESSION的生存时间。
  6. springMVC和mybatis整合,jsp对时间进行格式化
  7. C# XSD校验XML文件的代码
  8. .NET Interop.SHDocVw和MSHTML引用如何操作
  9. 山东省第四届ACM省赛
  10. MFC 一个类訪问还有一个类成员对象的成员变量值
  11. php 排序
  12. Apache Kafka系列(一)
  13. 51NOD 1258&#160;序列求和&#160;V4 [任意模数fft 多项式求逆元 伯努利数]
  14. VFIO PF SRIOV IOMMU UIO概念解释、关联
  15. kettle在centos7下部署分布式集群
  16. JavaScript判断系统语言
  17. man rpcbind(rpcbind中文手册)
  18. (后端)mybatis中使用Java8的日期LocalDate、LocalDateTime
  19. GPS日常总结
  20. .15-浅析webpack源码之WebpackOptionsApply模块-plugin事件流总览

热门文章

  1. 让tomcat启动时,自动加载你的项目
  2. html5--4-3 source元素-解决浏览器的兼容
  3. 【Selenium】IE浏览器启动问题
  4. [转]text和content方法的区别
  5. elasticsearch function_score Query——文档排序结果的最后一道墙
  6. 机器学习: Linear Discriminant Analysis 线性判别分析
  7. attachEvent与addEventListener的区别 真实例子
  8. 运用Eclipse的Working Set,界面清爽多了
  9. Httpclient入门代码
  10. c语言中的# ## 可变参数宏 ...和_ _VA_ARGS_ _