The 3n + 1 problem

Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.



Consider the following algorithm: 





    1.      input n



    2.      print n



    3.      if n = 1 then STOP



    4.           if n is odd then n <- 3n + 1



    5.           else n <- n / 2



    6.      GOTO 2





Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 



It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that
0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 



Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 



For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
 
Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 



You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 



You can assume that no opperation overflows a 32-bit integer.
 
Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output
for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 
 
Sample Input
1 10
100 200
201 210
900 1000
 
Sample Output
1 10 20
100 200 125
201 210 89
900 1000 174
 
让你怎么做你就怎么做。

预计数据弱,不然直接做应该会超时(本来想写优化来着,没想到这题数据这么弱······)。

代码例如以下:

#include<cstdio>
int main(){
int n,m;
while(scanf("%d%d",&n,&m)==2){
int maxn=n>m?n:m;//没说n和m的大小,坑啊! int minx=n>m?m:n;
int maxx=0;
for(int i=minx;i<=maxn;i++){//总感觉这样会超时。看来数据不强啊
int x=i,sum=1;
while(x!=1){
if(x%2==0) x/=2;
else x=3*x+1;
sum++;
}
if(sum>maxx) maxx=sum;
}
printf("%d %d %d\n",n,m,maxx);
}
return 0;
}


最新文章

  1. 85 megacli-查看raid信息
  2. 真机测试及布署Code Sign error问题总结
  3. NHibernate和 FluentNHibernate
  4. javascript自动转换大小写
  5. CSS 兼容 总结
  6. iOS - UIStepper
  7. [TL-WR841N V5~V9] 如何当作无线交换机使用?
  8. VC++ 动态检测串口的热插拔(一)通过注册表实现
  9. akka 入门
  10. Oracle数据库和实例的区别
  11. Hello,Kubernetes
  12. [leetcode-513-Find Bottom Left Tree Value]
  13. vue的ajax请求之axios
  14. Django-restframework 之认证源码分析
  15. eclipse gradle插件 org.gradle.tooling.GradleConnectionException: Could not install Gradle distribution from &#39;https://services.gradle.org/distributions/gradle-3.4-bin.zip&#39;.
  16. gearman中worker常驻后台,导致MySQL server has gone away
  17. GBDT原理
  18. React半科普文
  19. numpy.linspace()等差数列函数
  20. 国内能用的NTP服务器及和标准源的偏差值

热门文章

  1. wordpress无法登录的解决方法
  2. centos7中的网卡一致性命名规则、网卡重命名方法
  3. 九度oj 题目1125:大整数的因子
  4. LeetCode--二分查找相关算法
  5. shell的while循环
  6. Java面向对象三大特征
  7. Redis常见配置redis.conf
  8. es6 箭头函数 map、find
  9. 【Codeforces Round #503 (Div. 2)】
  10. spring-Ioc容器与bean