The Triangle

时间限制:1000 ms  |  内存限制:65535 KB
难度:4
描述

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.
输出
Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
样例输出
30

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define MAX 210
int dp[MAX][MAX];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=i;j++)
scanf("%d",&dp[i][j]);
}
for(int i=n-1;i>=1;i--)
{
for(int j=1;j<=n;j++)
dp[i][j]+=max(dp[i+1][j],dp[i+1][j+1]);
}
printf("%d\n",dp[1][1]);
}
return 0;
}


最新文章

  1. EF优缺点的理解
  2. Ruby之基础介绍(二)
  3. Macbook无法上网,访问不了appstore、safria、网易云等,但QQ、谷歌浏览器可以用--解决方案
  4. CodeForces 371D Vessels(树状数组)
  5. json根据key取values
  6. C语言预处理命令之条件编译
  7. jquery在线手册
  8. 百度VS高德:LBS开发平台ios SDK对比评测
  9. Outlook 2007无法打开链接&quot;由于本机的限制 该操作已被取消&quot;
  10. Java知识点:javac命令
  11. MySQL 分区表 partition线上修改分区字段,后续进一步学习partition (1)
  12. Android开发实例之闹钟提醒
  13. jquery 动态生成元素 事件
  14. OC语言大总结(下)
  15. django模板中获取域名地址
  16. cocos2d JS 源生js实现each方法
  17. 使用PHP进行SOCKET编程
  18. 【ZOJ2278】Fight for Food(dp)
  19. 一个将lambda字符串转化为lambda表达式的公共类
  20. EasyUI-Tree的使用

热门文章

  1. 百度编辑器图片在线流量返回url改动
  2. 使用roslyn编译website项目
  3. Ubuntu开机报错:could not update ICEauthority file /home/user/.ICEauthority(转载)
  4. 主流的Python领域和框架--转
  5. 前端将图片二进制流显示在html端
  6. 《鸟哥的Linux私房菜》笔记——03. 磁盘分区
  7. Unity脚本中可以引用的类型
  8. 脚本_统计固定时间段服务器的访问量.sh
  9. git--客户端管理工具初步使用
  10. Python学习笔记(4)列表