Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 1459    Accepted Submission(s): 413
Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.



We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array
a1,a2,…,an,
is it almost sorted?
 
Input
The first line contains an integer
T
indicating the total number of test cases. Each test case starts with an integer
n
in one line, then one line with n
integers a1,a2,…,an.



1≤T≤2000

2≤n≤105

1≤ai≤105

There are at most 20 test cases with n>1000.
 
Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 
Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
 
Sample Output
YES
YES
NO
 
Source
 
Recommend
hujie   |   We have carefully selected several similar problems for you:  5609 5608 5607 5605 5604 

给你一个数列,找到一个非递减数列,正反两次LIS就行,好久不用upper_bound写了不对,
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int a[100100],b[100100],s[100100];
int Find(int l,int r,int val)
{
int mid;
while(l<=r)
{
mid=(l+r)>>1;
if(s[mid]>val)
r=mid-1;
else
l=mid+1;
}
return l;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(s,0,sizeof(s));
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
for(int i=0;i<n;i++)
b[n-1-i]=a[i];
int len=1;
s[0]=-1;
for(int i=0;i<n;i++)
{
if(a[i]>=s[len-1])
s[len++]=a[i];
else
{
s[len]=10000000;
// int q=lower_bound(s,s+len,a[i])-s;
int q=Find(0,len,a[i]);
if(q==len)
len++;
s[q]=a[i];
}
}
if(len-1>=n-1)
{
printf("YES\n");
continue;
}
else
{
int len=1;
memset(s,0,sizeof(s));
s[0]=-1;
for(int i=0;i<n;i++)
{
if(b[i]>s[len-1])
s[len++]=b[i];
else
{
s[len]=10000000;
int q=Find(0,len,b[i]);
if(q==len)
len++;
s[q]=b[i];
}
}
if(len-1>=n-1)
printf("YES\n");
else printf("NO\n");
}
}
return 0;
}

最新文章

  1. MyCat源码分析系列之——配置信息和启动流程
  2. 使用maven搭建SpringMVC项目环境
  3. CentOS 常用命令大全(2)
  4. JSOI2008最大数(线段树)
  5. CI 笔记2,(命令规范等)
  6. js中call、apply、bind那些事
  7. JS高级编程读书笔记
  8. CF374 Journey
  9. Java开源生鲜电商平台-财务系统模块的设计与架构(源码可下载)
  10. Python性能分析
  11. python基础(3)-pycharm安装&amp;for循环&amp;format字符串&amp;list列表&amp;set集合使用
  12. Node.js webpack Vue-CLI --安装
  13. 模拟ssh、黏包、hashlib模块
  14. PHP 修改目录下所有与文件夹重名的前缀文件为index.后缀
  15. layedit富文本编辑器获取纯文字内容和全部内容
  16. Go_20: Golang 中 time 包的使用
  17. java String字符串
  18. MassiGra045 简体中文化|打开图片很快
  19. android模拟按键问题总结[使用IWindowManager.injectKeyEvent方法](转)
  20. Unicode 和 UTF-8 有何区别

热门文章

  1. POJ 3620 DFS
  2. python字符串中的单双引
  3. Android进程与线程
  4. ModelState对象
  5. 解决java float double 浮点型参与计算失精度
  6. ML:自然语言处理NLP面试题
  7. python tips:类的动态绑定
  8. Windows批量查找文件
  9. JS 100内与7相关的数
  10. 洛谷P3195 [HNOI2008]玩具装箱TOY 斜率优化