Time Limit: 2000MS   Memory Limit: 262144KB   64bit IO Format: %I64d & %I64u

Submit
Status

Description

Famil Door wants to celebrate his birthday with his friends from Far Far Away. He has
n friends and each of them can come to the party in a specific range of days of the year from
ai to
bi. Of course, Famil Door wants to have as many friends celebrating together with him as possible.

Far cars are as weird as Far Far Away citizens, so they can only carry two people of opposite gender, that is exactly one male and one female. However, Far is so far from here that no other transportation may be used to get to the party.

Famil Door should select some day of the year and invite some of his friends, such that they all are available at this moment and the number of male friends invited is equal to the number of female friends invited. Find the maximum number of friends that
may present at the party.

Input

The first line of the input contains a single integer n (1 ≤ n ≤ 5000) — then number of Famil Door's friends.

Then follow n lines, that describe the friends. Each line starts with a capital letter 'F' for female friends and with a capital letter 'M'
for male friends. Then follow two integers ai and
bi (1 ≤ ai ≤ bi ≤ 366), providing that the
i-th friend can come to the party from day
ai to day
bi inclusive.

Output

Print the maximum number of people that may come to Famil Door's party.

Sample Input

Input
4
M 151 307
F 343 352
F 117 145
M 24 128
Output
2
Input
6
M 128 130
F 128 131
F 131 140
F 131 141
M 131 200
M 140 200
Output
4

Sample Output

Hint

In the first sample, friends 3 and
4 can come on any day in range [117, 128].

In the second sample, friends with indices 3,
4, 5 and 6 can come on day
140.

n个人在任意一个时间段到达,有男有女,求人最多的时候有多少,并且男等于女

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[2][500];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
char op[2];
int x,y;
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
scanf("%s%d%d",op,&x,&y);
int t=1;
if(op[0]=='M') t=0;
for(int j=x;j<=y;j++)
a[t][j]++;
}
int ans=0;
for(int i=0;i<=366;i++)
ans=max(ans,min(a[0][i],a[1][i]));
printf("%d\n",ans*2);
}
return 0;
}

最新文章

  1. C#进阶系列——WebApi 跨域问题解决方案:CORS
  2. libsvm数据处理初略流程
  3. 简单一键CENTOS6 安装PPTP VPN方法记录
  4. Python中的运算符
  5. Global和Globals
  6. delphi7如何实现 科学计数的转换。 比如我输入2,触发之后会转换成2.000000E+00.求赐教
  7. 银行B2C直连
  8. SQL SERVER中如何格式化日期(转)
  9. spark第一篇--简介,应用场景和基本原理
  10. EALayout 实践
  11. MySQL(一) -- MySQL学习路线、数据库的基础、关系型数据库、关键字说明、SQL、MySQL数据库、MySQL服务器对象、SQL的基本操作、库操作、表操作、数据操作、中文数据问题、 校对集问题、web乱码问题
  12. 在Tomcat中配置连接池和数据源
  13. gitlab图形化使用教程 (mtm推荐)
  14. 使用VNC连接管理VPS
  15. 【转】系统去掉 Android 4.4.2 的StatusBar和NavigationBar
  16. Python实现类似JavaScript 的Json对象
  17. jdk1.8.0_45源码解读——LinkedList的实现
  18. 征信接口调用,解析(xml)
  19. [EffectiveC++]item12:copy all parts of an object
  20. LOSF海量小文件问题解决思路及开源库

热门文章

  1. php判断form数据是否为POST而来,判断数据提交方式
  2. 使用FastReport的BarCode2D控件生成含中文的PDF417条形码
  3. 3星|《商业周刊中文版:2017商业人物(下)》:酒店才应该是出行住宿的最佳选择,Airbnb不是
  4. mounted钩子问题
  5. switch方法中使用数字区间
  6. centos7mini版安装pyenv,ipython和jupyter环境.2090513
  7. 51nod1006 -最长公共子序列Lcs【动态规划】
  8. (蓝桥杯)第八届A组C/C++方格分割
  9. 6.4.1 标准库 os、os.path 与 shutil 简介
  10. Ubuntu 安装有道词典