转载请注明出处:

viewmode=contents">http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://poj.org/problem?

id=1068


Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 

q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 

q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 



Following is an example of the above encodings:

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed
string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

题意:

一组括号 (((( ) ( ) ( ) ) ) )



有两种描写叙述方法:



P方法:4 5 6 6 6 6 - 每个‘)’前,有几个‘(’



W方法:1 1 1 4 5 6 - 每个‘)‘的前面第几个(注意是从当前位置往前面数)’(‘是跟它匹配的



要求是依据P求W

思路:

先依据P还原出括号的位置,在计算出W就可以。

代码例如以下:

#include <iostream>
using namespace std;
#include <cstring>
#define N 117
char s[10000];
int n;
int i, j, k, l;
int p[N],w[N], flag[N];
void WW()
{
int x = 1;
int count = 0;
for(i = 1; i < l; i++)
{
if(s[i] == ')')
{
for(j = i-1; j >= 1; j--)
{
if(s[j] == '(')
count++;
if(flag[j] == 0 && s[j] == '(')
{
flag[j] = 1;
w[x++] = count;
break;
}
}
count = 0;
}
}
}
int main()
{
int t;
while(cin >> t)
{
while(t--)
{
memset(flag,0,sizeof(flag));
cin >> n;
k = 0, l = 1;
for(i = 1; i <= n; i++)
{
cin >> p[i];
for(j = 1; j <= p[i] - k; j++)
{
s[l++] = '(';
}
s[l++] = ')';
k = p[i];
}
// cout<<s<<endl;
WW();
for(i = 1; i < n; i++)
{
cout<<w[i]<<' ';
}
cout<<w[n]<<endl;
}
}
return 0;
}

最新文章

  1. CSS实现正方体旋转
  2. python基础知识5——赋值与深浅拷贝——整数和字符串,列表元组字典
  3. Java for LintCode 验证二叉查找树
  4. x264_param_t结构体参数分析
  5. 【HDOJ】【1512】Monkey King
  6. Spring3 报org.aopalliance.intercept.MethodInterceptor问题解决方法
  7. lua中的时间函数
  8. (转载)log4net 组件详解
  9. c#关于委托和事件
  10. Swift供选链接
  11. java字节中的基本类型的职业的数目 (采访总是问)
  12. 设计模式 -- 责任链模式或者叫职责链模式(Chain of Responsibility(CoR))
  13. 201521123114 《Java程序设计》第13周学习总结
  14. hdu 1520 Anniversary party(入门树形DP)
  15. 在linux上手动搭建svn服务器
  16. jquery 查找子窗口
  17. DNS推荐
  18. linux php5.6 安装Redis扩展
  19. Nginx缓存配置以及nginx ngx_cache_purge模块的使用
  20. Daily Scrum 10.23

热门文章

  1. vs项目结构解析
  2. python框架之Flask基础篇(二)-------- 数据库的操作
  3. Java—将文件压缩为zip文件
  4. mongoDB 删除集合后,空间不释放的解决方法
  5. 4th 循环结构概述和for语句的格式及其使用
  6. Git 分支创建
  7. eclipse版本和jdk的版本兼容问题
  8. privot函数使用
  9. MFC cstring 型转化成 double型
  10. 多目标跟踪笔记二:Efficient Algorithms for Finding the K Best Paths Through a Trellis