ZCC Loves Codefires

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 823 Accepted Submission(s): 438

Problem Description
Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".

It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan.

But why?

Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the best title of Codefires.
Besides, he is famous for his coding speed and the achievement in the field of Data Structures.

After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible.

What is score?

In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time.

Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the minimal score he will lose.(that is, the sum of Ki*Ti).

Input
The first line contains an integer N(1≤N≤10^5), the number of problem in the round.

The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem.

The last line contains N integers Ki(1≤Ki≤10^4), as was described.
Output
One integer L, the minimal score he will lose.
Sample Input
3
10 10 20
1 2 3
Sample Output
150
Hint
Memset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second.
L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150.
Author
镇海中学
Source
分析:如果一种情况的做完题的先后顺序确定,那么失分也就确定,如今失分要尽可能的小,那么就得交换位置,如果 i 与 j 是相邻的位置,那么交换两个相邻位置就仅仅有一个值在变 Ei*Kj ---->  Ej*Ki,所以要交换得满足条件:Ei*Kj >Ej*Ki   <==> Ei/Ki > Ej/Kj 。
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
int e,k;
double f;
};
bool cmp(node a,node b)
{
return a.f<b.f;
}
node a[100005];
int main()
{
int n;
__int64 sumt=0,ans=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i].e);
for(int i=0;i<n;i++)
scanf("%d",&a[i].k),a[i].f=1.0*a[i].e/a[i].k;
sort(a,a+n,cmp);
for(int i=0;i<n;i++)
{
ans+=(sumt+a[i].e)*a[i].k; sumt+=a[i].e;
}
printf("%I64d\n",ans);
}

最新文章

  1. Ubuntu Server 设置PPTP客户端连接
  2. Linux 进程与线程五
  3. 关于 jquery和js获取宽度时只能取整数,取不到小数点
  4. Flex 关闭浏览器
  5. CEF3开发者系列之JS与C++交互之二
  6. Css 特殊或不常用属性
  7. ssh scp ssh-copy-id 非22端口的操作方法
  8. 2014北邮新生归来赛解题报告a-c
  9. C# 实例化接口对象
  10. ios7去除手势滑动返回
  11. 4、第4次课 CSS代码第三节课20150923
  12. xen虚拟机操作整理
  13. Lua学习笔记4. coroutine协同程序和文件I/O、错误处理
  14. html - 表单form
  15. 新建WINDOWS服务C#
  16. OpenCV3 for python3 学习笔记3-----用OpenCV3处理图像2
  17. LevelDB源码分析-Compact
  18. LeetCode算法笔记目录
  19. Oracle Database(rdbms) 12.2 安装组件
  20. linux中uptime命令查看linux系统负载

热门文章

  1. nginx深入
  2. Spark RDD/Core 编程 API入门系列之简单移动互联网数据(五)
  3. AdminLTE介绍和zTree的简单使用
  4. HTML中的行级标签和块级标签 《转换》
  5. Android常用的Dialog对话框用法
  6. JS高级——apply与call
  7. 如何快速获取yun2win app key?
  8. Centos6.7 ELK日志系统部署
  9. HTML5轻松实现全屏视频背景
  10. iptables详解(3):iptables规则管理